Welcome to the Spectrum Community

Get answers, share solutions, help your community.

Start here

Why are some email servers apparently running without valid SSL certificates?

mtiedemtiede Posts: 7 ✭✭✭
in Email Aug 31, 2020

Maybe a year or so ago, I had issues with the mail servers. I was told by a Spectrum person that they were going to get new servers for email and there had been a delay in implementing that. So the old server's SSL certificates expired. Eventually, they appeared to move to the new servers. But for a week or so now, I have been having trouble with connecting via IMAP using Outlook for Android. It says the SSL certificate is invalid and refuses to do the connection.

When I use this website:

https://ssl-tools.net/mailservers/roadrunner.com

To test the server, I get certificate errors saying a Sample certificate is being used. That would probably cause Outlook for Android to not be able to connect.

I'm guessing that SOME servers do have valid certificates as I am trying with 3 different email accounts and only one seems to consistently have problems. I'm guessing that the server farm has somehow parcelled out the same server for this account and that server is one with invalid SSL.

Though admittedly, I don't know if that web site is validating the right server.

Here is where it says the certificate is "self-signed" (and therefore not secure)

Can someone please fix the certificates so that mail clients that TEST for valid certificates can work as they should?

Replies

  • James_MJames_M Posts: 2,340 ADMIN
    Sep 01, 2020


    I've included a link to Spectrum Email Server Settings that you may find helpful as well as a screen shot of the settings and ports for IMAP.


  • mtiedemtiede Posts: 7 ✭✭✭
    edited September 2 Sep 02, 2020

    As I said, I've been using roadrunner mail for a long time. I've entered the proper settings maybe a 1000 times. So I am aware of the settings. And they don't work all the time.

    As I said, apparently there are bad SSL certificates on some email servers at Spectrum. The phone is refusing to connect BECAUSE of the SSL certificates and the image I included appears to show that the certificate is a Sample and self-signed so not to be trusted.

    What about my question? When will the certificates be fixed?

  • Julia_RJulia_R Posts: 4,341 Lead Mod
    Sep 02, 2020


    Good morning!

    We wanted to get back to you to ask that you check to make sure that you are using mail.twc.com for your servers.

    We also wanted to advise you that the testing on the server that you did was not hitting the correct server, the SSL on that server would not negatively impact the sending or receiving of mail, no worries there.


    We were looking into this issue and have put in place a fix for the issue, if you will please check to ensure that you are using mail.twc.com for those and that the full email is used, in your case @roadrunner.com, not @rr.com.


    Hope you are having a good day!


    Julia_R

  • mtiedemtiede Posts: 7 ✭✭✭
    edited September 5 Sep 05, 2020

    If you read my post, you would know that I have tried the correct settings 1000s of times. The correct settings were working until apparently some mail server's SSL certificate expired. And the correct settings work with other email clients. But apparently Microsoft added some additional tests to make sure we don't connect to an insecure server. Otherwise users and passwords could go over the internet in plain text which is not a good thing.

    So how can I run that test on the "correct server"? The test just said to enter the domain of the email address which is correctly "roadrunner.com". I'm guessing that there is a server farm so there is no way for me to check that as far as I can tell because I don't know which server the Outlook client is trying to connect to.


    If you "put in place a fix for the issue", the fix isn't working. I still can't connect and Outlook for Android reports that it is an invalid SSL certificate.


    Since that is a Microsoft test site and the email address contains @roadrunner.com, I might expect Microsoft's client to say the SSL is invalid because the test says it is. Even though the mail will get routed to mail.twc.com eventually. So, since I can't look at their code, I assume either the one that I posted caused the problem, or else the final one. But my best guess is that the test is doing the same thing the client is and that server has a bad certificate.


    Last point. If that server I tested HAS an SSL then it must need it for something. And the certificate it has in invalid. So the certificate should either be removed, or it needs to be valid.

  • SerpentineSerpentine Posts: 6 ✭✭
    Oct 07, 2020

    I have a similar problem in Outlook and iOs starting today 10/7/2020. No problem on webmail. Spectrum, can you fix this please? You may have noticed a lot of people are working remotely and need email service more than ever. Thanks.

Sign In or Register to comment.