Welcome to the Spectrum Community

Get answers, share solutions, help your community.

Start here

Google Chromecast and Wave 2 Router Compatibility?

adamschafferadamschaffer Posts: 2 ✭✭
edited September 29 in Connectivity Sep 29, 2020

Recently upgraded service (old Time Warner customer) and received a new cable modem (TM1602A MTA) and WiFi Router (RAC2V1A). Internet connectivity is ok and I have been able to reestablish connectivity for all my connected devices (thermostat, vacuum, security, laptops, phones) except for 1 - the Google Chromecast. Despite allowing me to go through the setup in the Google Home application, I am unable to cast to my TV from either an Iphone or Android. I called Google and they said it was an issue with the Wave 2 routers with model numbers RACV1A, RACV1K to RAC2V1A, RAC2V1K. Specifically, I was told that a default setting on the router is preventing my devices (phone and chromecast) from communicating with each other. A call to Spectrum customer support was fruitless as they were not aware of the issue/no notes on it in their database of known issues.

Anyone else experience this issue and solved it? Before I attempt to bring my equipment to a Spectrum store for a swap, which is what I was advised to do by Google, for a compatible router if that even exists, I want to see if there are any other options to resolve issue.

Comments

  • NBFelix123NBFelix123 Posts: 1
    Oct 01, 2020

    I have the same problem. I switched from AT&T internet, which chromecast used to work on flawlessly. I've not been able to figure out a fix for over 6 months and just learned to live without chromecast. Customer service with spectrum was useless for me as well. I've read if you go to a Spectrum store you can exchange your current routher/modem for something that is compatible but I havent wanted to spend my nights/weekends doing so.

  • Lake802Lake802 Posts: 9 ✭✭✭
    Oct 01, 2020

    Hello Adam and Felix - there are a couple different issues that can cause connection problems with Chromecast. Part of it depends of which version of the Chromecast device you have.

    In general, You can toggle a setting on Wave2 routers to address chromecast gremlins/compatibility issues.

    Login to the local Wave2 router.

    In many but not all cases it will be accessible at 192.168.1.1

    Click advanced, click Wi-fi2.4ghz, click advanced,

    under WMM Wi-Fi Multimedia, toggle the green Enable button to off. Click Apply.

    Do the same steps for Wi-fi 5Ghz.

    In many cases that will resolve the chromecast issue although there are benefits to leaving WMM on.

    If you still have trouble with chrome cast, google released an updated tool back in August to help folks troubleshoot/resolve chromecast connection issues on wifi. It is accessible here https://support.google.com/chromecast/workflow/9865398?hl=en

    Please let us know if that helps resolve the chromecast problems.

  • adamschafferadamschaffer Posts: 2 ✭✭
    Oct 01, 2020

    TL;DR Swapping your router for a different version of the same model may fix the Chromecast connectivity/casting issue. Not sure why, but it worked for me.

    Longer response...

    Lake 802 - thanks very much for your reply.

    As it turns out, I had other equipment to return to Spectrum (the old router and modem the Wave 2 replaced). I brought my Wave 2 router with me and thought they might be able to swap with a compatible model. I discussed the situation with the customer service reps and they were not aware of any issues similar to mine.. And despite what Google told me, there are no other models to swap with for the level of service I have (400mb). Just wanting to do something, I took a new router, same model as the one I had. Once I connected it I tested with the Chromecast and found I was able to cast to it One caveat - I used to see a Pin number in the top right of the screen and I don't see that anymore, but I don't log into the Chromecast that way so no real harm. Would be good to know why it works but if it ain't broke (anymore), don't fix it.

    Incidentally, I looked at the setting you suggested and while it is enabled within the Wi-Fi 2.4Ghz card, the Advanced>Wi-Fi 2.4Ghz status itself shows as disconnected with a red x. I am not sure what that means since my access is active, but that may an issue for another day. 😉

Sign In or Register to comment.