App Connectivity Issue

To watch most shows on the Spectrum TV app I have to connect to Spectrum wifi. I connect to wifi and there is no problem until I choose a show. It takes several minutes for video to play, and sometimes only audio plays. Why is this, when there is no issue with the wifi?

Replies

  • Tyleen_ZTyleen_Z Posts: 353 ✭✭✭✭
    Nov 13, 2020

    Hello and welcome to the Spectrum Community.

    With our app the content is limited when away from home and needs to be connected to the wifi for the full lineup.

    As for the issues make sure you are connected to the wifi before opening the app. If you turn on the wifi after opening the app it may need to be closed and reopened to recognize being connected to the wifi.

    -Tyleen

  • lyssamichelle89lyssamichelle89 Posts: 6 ✭✭
    Nov 13, 2020

    I turn on wifi on my phone, for example, and wait a few minutes before opening the tv app. It still takes several minutes for the app to work properly, if at all.

  • James_MJames_M Posts: 2,438 ADMIN
    Nov 13, 2020

    What is the model device you are using and which version of the app is installed?

  • lyssamichelle89lyssamichelle89 Posts: 6 ✭✭
    Nov 13, 2020

    I use a Samsung Galaxy S8 phone. App version is 8.11.0.8687138.

  • James_MJames_M Posts: 2,438 ADMIN
    Nov 18, 2020

    There was a recent update to the app,. have you tried deleting and reinstalling the app?

  • lyssamichelle89lyssamichelle89 Posts: 6 ✭✭
    Nov 18, 2020

    I've tried this too, but it hasn't helped. My app version is the latest available version from the Play Store.

  • James_MJames_M Posts: 2,438 ADMIN
    Nov 19, 2020

    Are you getting an error message(s)? If possible, screen shots are helpful.

  • lyssamichelle89lyssamichelle89 Posts: 6 ✭✭
    Nov 19, 2020

    There are usually not any error messages. Just a black screen with a loading circle where a show would normally play. The channel guide loads just fine with the rest of the app- it's that playback space which seems to take a while.

  • Julia_RJulia_R Posts: 4,407 Lead Mod
    Nov 19, 2020


    When you say most shows, do you mean live and On Demand or just one or the other? What you are describing is buffering most often caused by connection issues. It could be the internet connection its self, the wireless connection or even how the phone is doing. Do you have a lot of other apps open while trying to use ours?


    One thing I would have you test is to close those other apps, restart the phone and give it another go.


    Julia_R

  • lyssamichelle89lyssamichelle89 Posts: 6 ✭✭
    Nov 19, 2020

    I have this issue only with live shows. On Demand shows load quickly.

    I've tried resetting, restarting, clearing background apps... everything.

  • Julia_RJulia_R Posts: 4,407 Lead Mod
    Nov 19, 2020


    Since the On Demand pre-buffers a bit and the Live TV does not it is most likely to be a connection issue.

    Do you have other devices? If so do you experience the trouble with Live TV there as well?


    If you will also please unplug your modem and router (if you are using a connected router and not an all in one) for about 1 minute. Please plug back in the modem first and let it completely reboot. Once that happens please go ahead and plug in the router.

    For good measure then powercycle the phone and reconnect to the wireless if needed before re-testing.


    Julia_R

Sign In or Register to comment.