Chromecast 3rd Gen Not Connecting

Ripper0412Ripper0412 Posts: 2 ✭✭
edited January 12 in Spectrum TV App Feedback for Other Devices Jan 12, 2021

Hello,

I have a 3rd Generation Chromecast device. It has been working fine for months. I moved to a new house and received a new internet modem and new wireless router. I've tried using the 2 ghz and 5 ghz connections and I've checked my router setting to make sure UPnP is ENABLED and AP Isolation is DISABLED. I have also unplugged and rebooted the modem and router multiple times and did the factory reset multiple times.

Every scenario gives the same result. On my TV screen I see "Setup Complete - Your chromecast has been set up but can't be found"

Best Answer

  • James_MJames_M Posts: 2,580 ADMIN
    Jan 12, 2021 Accepted Answer

    Thanks. I was able to locate your account based on your registration information. I am not seeing a video subscription. If your internet is working correctly, I would suggest contacting Chromecast Help / Google Support for further assistance.

Replies

  • James_MJames_M Posts: 2,580 ADMIN
    Jan 12, 2021

    Are you trying to use Chromecast with the Spectrum TV app?

  • Ripper0412Ripper0412 Posts: 2 ✭✭
    Jan 12, 2021

    No. It is a Samsung TV from 2009. It is not a smart TV. Everything is the same from my old house except the Spectrum Equipment. The tv/chromecast are in the same room as the wireless router as well.

Sign In or Register to comment.