Before posting a new question, please check out our Internet / WiFi and Spectrum TV App troubleshooting pages for common issues, as well as useful information to include in your post.

Advanced Search Options


We have advanced search options to make it easier to locate posts, questions and answers on this community.
More information can be found at Advanced Search Options
If you are looking for something specific, please check if someone else has already asked or answered the same question.

Upload bandwidth unstable after months with no issue streaming. What is causing this?

MichaelKyleMMichaelKyleM Posts: 5 Spectator
edited May 3 in Connectivity Mar 28, 2022

I have been streaming on Twitch now for over 4 months. I have never had an issue with stream quality or bandwidth. Starting two Saturdays ago I started experiencing a ton of dropped frames while I'm trying to stream. This indicates a network issue. I had a tech out twice the past two weeks and had two service calls and some equipment was replaced, but the issue is still occurring. I've tried streaming with every single device in the house disconnected and running on ethernet, and the bandwidth issues still occur. I even tried streaming on an entirely separate computer and the issue was still there. I've done a bunch of tests that point to an issue with Spectrums nodes. I pay for gig-service so my internet should be more than enough to handle streaming on Twitch at 1080p.

I have attached pictures showing major packetloss on several Charter servers while trying to connect to Twitch servers. I tried streaming last night at 11PM and actually had no issues, but all today I've been trying and my bandwidth is unstable the entire time I try to stream.

This issue has only persisted the past couple weeks, so something is going on with the nodes down the line. I pay a lot of money for this internet service, and need it to run optimally for work. How can this issue be resolved?

Thanks.


Replies

  • Heather_THeather_T Posts: 114 Moderator
    Mar 28, 2022

    Hello @MichaelKyleM. Welcome to the Community!

    I'm so sorry you're still having trouble with this. We definitely want to make sure your service is working properly. I did take a look at your connection and modem logs for the last few days and I do still some errors specifically on the upstream side. If you'd like I would be more than happy to have a technician come back out and look into this further for you.

    -Heather

  • MichaelKyleMMichaelKyleM Posts: 5 Spectator
    Mar 28, 2022

    @Heather_T That would be great. I'm hoping a bad modem is all it is.

    Thanks,

    Michael

  • Randy_SRandy_S Posts: 296 Moderator
    Mar 28, 2022

    @MichaelKyleM , I just sent you a message from our Community_Help handle concerning the follow up appointment.

    Randy

  • MichaelKyleMMichaelKyleM Posts: 5 Spectator
    Mar 29, 2022

    Hello @Randy_S and @Heather_T,

    The tech just left my house. They replaced the modem, so now all the equipment in the house in brand new. I just tried a couple tests now, and I'm still having the same issue with the upstream bandwidth instability. I also tried streaming using WiFi to rule out my ethernet cable and the same issue persists.

    You can see in the above pictures I'm losing 23% of my frames when uploading, and none of the connections to the servers are stable. They all have a quality rating of 0 out of 100. It looks like there are issues with the nodes down the line when trying to upload my stream. Is this uploaded data being flagged and lost? Can the nodes be checked? I hope this issue can be resolved because it's been going on for almost 3 weeks now.

    Thanks,

    Michael

  • Randy_SRandy_S Posts: 296 Moderator
    Mar 29, 2022

    I apologize this is happening. I will message you again on our private message conversation.

    Randy

  • AshesAshes Posts: 2 Spectator
    Apr 05, 2022

    I've had the same issue since September of 2021. Hasn't been resolved.

    Things I tried:

    1. 20 techs came out. they just did basic stuff. rewired, changed equipment, etc.
    2. upgraded to Business account gig. same issue.
    3. Ended up moving to new address. New account and new equipment. Same issue at a brand new Apartment building
    4. Regional tech manager said it wasn't a Spectrum issue but a Twitch service issue which is BS cause same thing happens when I stream to YouTube and restream. Showed him graphs with data for everything. HE gave up and stopped helping
    5. ended up making a new account and hoping that it would work but same issue.
    6. Bought my own equipment and same issue.
    7. yes i also did different computers
    8. Tried a TMobile ISP for uploading and guess what, no issues at all.

    Basically Spectrum is scamming us with "40Mbps" upload, can't handle a basic constant 6Mbps upload to streaming sites (Twitch, YouTube, Facebook, etc)


    Also note that when testing, the ping fluctuates from 30ms all the way to 120ms. so it's unplayable.

  • MichaelKyleMMichaelKyleM Posts: 5 Spectator
    Apr 05, 2022

    @Ashes I have tried pretty much everything you listed except for switching to a new ISP. I tried streaming to YouTube, Restream, and Twitch and the issue is there for all of them. I’ve switched the equipment, tried another computer in the house, and tried on Wifi and none of that changed anything.

    The worst part is the regional tech manager was supposed to reach out to me last week. I’ve been waiting for over a week for a call, but they won’t get in contact with me. I’ve reached out twice to someone at spectrum to have the tech manager contact me but still nothing.

    It’s very frustrating because spectrum has otherwise been okay. I think I may be forced to switch to a different ISP since spectrum is unwilling to resolve this.

  • AshesAshes Posts: 2 Spectator
    Apr 05, 2022

    Yeah, your best option is to get a different ISP if possible if you're taking streaming seriously. I'm currently waiting for some other ISP to become available. I was also ghosted by the Regional Tech manager so no help at all. They don't know what the Issue is, funny thing is that it started back in September of 2021 and no solution to it.

    It's out of our hands and too much work for them to want to proceed with other solutions to it. I'm sure we're getting capped on the Upload. Other best thing to do is get a cheap 2nd connection with at least 10 upload and try using that one for streaming while using the main connection for gaming.


    Best of luck and hope you get as much as credit as possible because we're getting screwed over.

  • MichaelKyleMMichaelKyleM Posts: 5 Spectator
    Apr 05, 2022

    @Ashes Thank you for the advice, I really appreciate it. It’s been really frustrating to deal with, as I’m sure you’re aware. The past month it’s been going on has made streaming unenjoyable, frustrating, and at times nearly impossible.

    I’m pretty confident we’re getting capped too. It seems clear from all the tests I ran.

    Thanks so much again, and best of luck to yourself as well.

This discussion has been closed.