Before posting a new question, please check out our Internet / WiFi and Spectrum TV App troubleshooting pages for common issues, as well as useful information to include in your post.

Advanced Search Options


We have advanced search options to make it easier to locate posts, questions and answers on this community.
More information can be found at Advanced Search Options
If you are looking for something specific, please check if someone else has already asked or answered the same question.

My Spectrum App won’t open on iPhone or iPad

pbgdmgpbgdmg Posts: 25 Contributor

I’m running ios 15.4.1 on both. I deleted the app, and downloaded a new one from the App Store. No help. I re-booted the iPad no help. The app just brings up the welcome to my spectrum startup page with a busy icon - never opens

Replies

  • Renee_TRenee_T Posts: 213 Moderator
    May 08, 2022

    I'm sorry to hear about the app issues. It sounds like it may be a caching issue. When you deleted the app, did you reboot either the iPad or iPhone prior to reinstalling it?

  • pbgdmgpbgdmg Posts: 25 Contributor
    May 09, 2022

    I’ll try that

  • pbgdmgpbgdmg Posts: 25 Contributor
    May 09, 2022

    That didn’t help.. I don’t know exactly what day it last worked correctly. I believe I used it after the last time Spectrum came out to check my equipment. I think that was about two months ago. Do you have a way to look in Spectrum records to see when my last service call was when the technicians were here at my house?

    The app has been updated 7 times in the past two months. I don’t know what version I was using when it worked last.

    without the app, I can’t see on the Spectrum web pages how to read the Client Hex and IP addresses from the Spectrum router. The app had a link in it to do that. I don’t see a link anywhere on the web page - which is my only option since the app is non-functional

  • Steph_SSteph_S Posts: 387 Moderator
    May 09, 2022

    Good morning! Can you please clear the cache on the iPad/iPhone by following these steps:

    1.   Go to Settings > General > Transfer or Reset iPad. If you're erasing your iPad because you're replacing it with a new iPad that you have on hand, you can use extra free storage in iCloud to move your apps and data to the new device. ...

    2.   Tap Erase All Content and Settings.

    Once that is completed please reboot the iPad/iPhone and then relaunch the My Spectrum app. If the same issue occurs are you able to provide the version of the My Spectrum app that you are using?

  • pbgdmgpbgdmg Posts: 25 Contributor
    May 09, 2022

    I’ve never had to completely erase an iOS device to get any app to work in the past. I shouldn’t have to go through all that

  • pbgdmgpbgdmg Posts: 25 Contributor
    May 09, 2022

    There’s something wrong with the app

  • pbgdmgpbgdmg Posts: 25 Contributor
    May 09, 2022

    Curiously, it finally opened. I left it on the trying to open startup screen, and after an hour I checked it and it had opened some time in that hour. Not sure what it was doing. Before that, I had stared at the busy icon trying to open for 10 minutes.


    BTW. The link that’s not on the web page that is in the app to view the router IP addresses is called: Manage Devices. It’s on the router details page in the app. I didn’t see it anywhere on the Spectrum support web pages. The only link I found on the web page was the View and Edit network info where my network name and password are. Seems like Spectrum should put the link to Manage Devices on the router web page.

Sign In or Register to comment.