Before posting a new question, please check out our Internet / WiFi and Spectrum TV App troubleshooting pages for common issues, as well as useful information to include in your post.

Advanced Search Options


We have advanced search options to make it easier to locate posts, questions and answers on this community.
More information can be found at Advanced Search Options
If you are looking for something specific, please check if someone else has already asked or answered the same question.

Spectrum TV app on my Samsung TV refuses to open PBS channel!

Raja_BRaja_B Posts: 4 Spectator
edited June 27 in Spectrum TV App Feedback for Other Devices May 18, 2022

This is so strange. At my home, using Roku and the Spectrum TV app, I have no issues watching Public TV (PBS). But on my 2018 Samsung TV, model QN55Q65FN, I am unable to do so! If I try, a blue ring goes in circles and I get an error code STLP-999.I tried deleting the app and reinstalling it. No good. The TV's WiFi is working perfectly and I can watch ANY OTHER CHANNEL I want! PBS is my most favorite channel! Hope you can fix this please, Samsung!!! I will likely go buy a Roku Stick today as I don't feel very optimistic that Samsung will resolve this problem.

Best Answer

  • Raja_BRaja_B Posts: 4 Spectator
    May 18, 2022 Answer ✓

    PROBLEM SOLVED, FOLKS! I called Spectrum, they had no solution and said to contact Samsung. Then I got an idea: I called Spectrum back and REQUESTED A MODEM RESET which the support rep did. And guess what, that solved the problem!!! Now I am able to watch PBS on the Spectrum TV app on my Samsung TV!!! What puzzles me is that when I did a modem reset myself, that did not solve the problem. Spectrum had to do the modem reset at their end. GO FIGURE.

Replies

  • James_MJames_M Posts: 3,495 ADMIN
    May 18, 2022

    Hi and welcome!

    Is the Samsung TV also in your home? If it is out of the home, then access to some channels is restricted. If it is in the home, try logging out of the app and log in again, to make sure you are using the correct credentials. Last, you can also try restarting the modem, since the app uses to modem to authenicate your channels.

    Thanks!

  • Raja_BRaja_B Posts: 4 Spectator
    May 18, 2022

    Hello James_M, please see my comment above. When Spectrum staff themselves reset my modem, that solved the problem! As I wrote above, when I reset the modem, that did not solve the problem and yet when Spectrum reset my modem, problem solved!!! And yes, my Samsung TV is at home. Bye for now!

  • 1Charlie21Charlie2 Posts: 1 Newcomer
    May 19, 2022

    I have the spectrum app on my samsung tv. All of a sudden when I go to the app all it says is that it is getting program data but nothing happens. It's like stuck. I tried going through the settings and it says everything is connected. I've unplugged it from the back of the tv and replugged it but it says the same thing. What else can I do?

  • Raja_BRaja_B Posts: 4 Spectator
    May 19, 2022

    1Charlie2, pls read above, I posted the solution. A Spectrum rep needs to reset your modem, and that will resolve your issue. It did mine.

This discussion has been closed.