Before posting a new question, please check out our Internet / WiFi and Spectrum TV App troubleshooting pages for common issues, as well as useful information to include in your post.

Advanced Search Options


We have advanced search options to make it easier to locate posts, questions and answers on this community.
More information can be found at Advanced Search Options
If you are looking for something specific, please check if someone else has already asked or answered the same question.
You are currently viewing the Spectrum Community Archives
This content may be outdated or inaccurate
All posts are closed and commenting has been disabled

If you have a question or comment, please start a new post (registration is required)

Leave the Archive

Hurricane Ian Update


Get the latest updates on storms affecting service in your area.
For customers in areas in the storms path, including Southwest and Central Florida, if your services are impacted, we are working to restore your service as soon as safely possible.

Live streaming is available free of charge for the duration of Hurricane Ian coverage whether or not you subscribe to Spectrum, on our websites at baynews9.com or mynews13.com and on our Spectrum News app which
can be downloaded at spectrumnewsapp.com

Our Spectrum WiFi access points will be available to the public at no cost from September 28-October 2 in Florida, Georgia and South Carolina

Unable to activate Apple Watch cellular plan

Customer304129313Customer304129313 Posts: 2 Spectator
edited September 27 in Spectrum Archives: 2020 - Present Aug 18, 2022

It appears this issue has been ongoing for several months for all new Apple Watch customers. I’ve tried escalating this to higher support tiers without much help. The issue is that after purchasing an Apple Watch plan when you go to activate the cellular plan on the watch you cannot log into your Spectrum account to attach. Thus you are never able to actually activate a cellular plan on your Apple Watch.

Hopefully, this can get resolved soon, based on numerous forum posts, Reddit posts, and talking to support … this is an issue that’s affecting everyone and has been for months. Seems odd this wouldn’t be resolved or caught by management seeming as you’ve had no Apple Watch activations for months (this issue is customers cannot activate!!).

So here are the steps to re-create the issue:

1) Purchase an Apple Watch cellular plan, wait a couple of hours and you will receive an order confirmation email, along with steps on how to activate the cellular plan on the watch,

2) The steps state to open the Apple Watch app on your iPhone,

3) In the Watch app on your iPhone, select “Cellular” and then “Set Up Cellular”,

4) Another popup appears, select “Set Up Cellular” again,

5) A Spectrum website will appear with some information about activating your Apple Watch Cellular Service, click "Continue",

6) A Spectrum login appears asking for the Username and Password of your Spectrum account, enter the username and password used to purchase the Apple Watch plan.

THE ISSUE IS THAT YOU CAN NEVER LOG INTO YOUR SPECTRUM ACCOUNT

After you have entered your correct credentials, you will receive an error message ”The info entered doesn’t match our records. Please try again.

Here is the screenshot of the exact error message:

Of course, I’ve gone through all the basic and recommended troubleshooting steps:

1) Reset username and password for Spectrum account. Doesn’t help. Positive I’m entering the same username and password that works on every other Spectrum login area.

2) Unpair Apple Watch, reset to factory, set up new. Doesn’t help. Just wasted like 30 minutes doing this only to get the same error message above.

3) Contact support. Doesn’t help. Most support I’ve contacted doesn’t even know what that screen is that’s causing the issue. THE SPECTRUM LOGIN REQUIRED TO ACTIVATE AN APPLE WATCH CELLULAR PLAN DOES NOT WORK. It’s not an Apple issue, it’s not an iPhone or Apple Watch issue. This is an issue specifically with this login screen and has been broken for months.

The only good news is that you are not charged for a plan purchased but not activated. So while I really do want my Apple Watch cellular plan to work, at least I’m not getting charged for it.

Tagged:

Comments

  • James_MJames_M Posts: 3,652 ADMIN
    Aug 18, 2022

    Hi and welcome!

    Sorry to hear about this issue. When you are calling, are you contacting Spectrum Mobile? The Spectrum Mobile and My Spectrum websites were recently merged and it sounds like you may have older account information associated with your log in that is causing the authentication to fail.

    It also looks like you are trying to authenticate on mobile, have you tried authenticating on desktop or laptop browser?

  • Customer304129313Customer304129313 Posts: 2 Spectator
    Aug 18, 2022

    I believe Spectrum Mobile? I dialed 611 from my cell phone.

    My username and password do work fine in a desktop browser, mobile browser, and even with the My Spectrum iPhone app. Never once have I had an issue with my credentials EXCEPT with this cellular activation page.

    Again this authentication has to be done on mobile. It has to be initiated from the iPhone that is paired with the Apple Watch you're looking to activate the cellular plan on. I would love to activate it from a desktop or laptop browser (where my credentials actually work) however that is not possible with Apple Watch activation.

    For further reference, here is the Spectrum help guide on activating an Apple Watch cellular plan:

    Step 9 is where this fails. It's impossible to Sign In without receiving that error, regardless if my credentials are correct.

  • James_MJames_M Posts: 3,652 ADMIN
    Aug 18, 2022

    Thanks! I was able to locate your account based on your registration information. My guess is that some wires may have got crossed when the mobile account was migrated and merged with the residential account. I am going to send an email to our mobile contacts and ask them to reach out and follow up with you directly with the contact number provided on the account (your mobile number).

    If you do not hear back by the end of the businesss day tomorrow, please let us know. I will also monitor for email updates and provide any new information when it becomes available.

    Thanks again, fingers crossed this is an easy fix.

  • activatemyapplewatchactivatemyapplewatch Posts: 1 Newcomer
    Aug 19, 2022

    Exact same issue here - unable to login to Spectrum within the Watch app but can login to Spectrum literally anywhere else. Moved over from another carrier on 8/5 with 2 iPhones and 1 Apple Watch w/ cellular. First time I activated the watch, I was able to login to my Spectrum account fine via the Apple Watch app. However, there was an issue with one of the iPhones not being able to make outbound calls so support deactivated and reactivated that iPhone (the one that was paired with the Apple Watch). This broke the Apple Watch and have not been able to reactivate it on the Spectrum network since because I can no longer login via the watch app. Have spent many hours of frustration on the phone with support. They claimed to have escalated to "Tier 4 support" well over a week ago, yet when we keep calling back nothing has been done. Get it together, Spectrum - this is basic stuff for a mobile service provider.

This discussion has been closed.