Before posting a new question, please check out our Internet / WiFi and Spectrum TV App troubleshooting pages for common issues, as well as useful information to include in your post.

Advanced Search Options


We have advanced search options to make it easier to locate posts, questions and answers on this community.
More information can be found at Advanced Search Options
If you are looking for something specific, please check if someone else has already asked or answered the same question.

Strange Router Problem - Only Smart devices are connecting

vikkeevikkee Posts: 5 Spectator
edited September 22 in Connectivity Aug 20, 2022

Facing this strange problem where only the smart devices in the house connect to the internet. Thanks in advance for any advice here!

Background:

Activated new spectrum Fiber internet service this week.

Plugged in my personal TP-Link AC1900 router. No internet. I can open spectrum.net but no other websites work on my laptop or my phone. BUT strangely, my Chromecast and Google home devices are working just fine!

Why would internet only work on select devices?


Device:

Modem: Spectrum ONU (SONU) Modem

Router: TP Link AC1900

Replies

  • William_MWilliam_M Posts: 396 Moderator
    Aug 20, 2022

    Hi @vikkee, welcome to our community!

    Are your devices unable to connect to WiFi at all, or are they connected just with no internet?

    Have you tried rebooting starting with just the modem first, and then waiting for the online light to come on solid before rebooting the router?

    If that does not help will you connect your laptop directly to the modem with an ethernet cable (bypassing the router,) rebooting the modem one more time, and then check if you have internet when the online light comes back on?

  • vikkeevikkee Posts: 5 Spectator
    Aug 20, 2022

    Hi @William_M thank you for checking my post!

    Yes, the devices are connecting to WiFi but the only website that works is spectrum.net. I am unable to open any other websites on my laptop or phone browser.

    However, the smart devices like my Google Home speakers, and Chromecast are working fine and connecting to the internet. I can give voice commands and it gives a response back.

    This problem only happens via my personal router. All websites work fine when bypassing the router and directly plugging modem and laptop via ethernet.

    Rebooting in the mentioned order also did not help and the problem remains. Thanks for any follow up thoughts you have on what to try next!

  • Paul_BPaul_B Posts: 535 Moderator
    Aug 20, 2022

    Hello @vikkee!

    One thing I would try is to disconnect one of the devices that is not connected from the WiFi and reconnect it to see if that changes anything. In order to do this, you would need to go into the Settings of the device and choose to "Forget" the network.

    Once you have done that, please reconnect to the network and see if that changes anything.

    Paul_B

  • vikkeevikkee Posts: 5 Spectator
    Aug 21, 2022

    Hi Paul_B, thanks for checking out my post!

    That's a great idea, I tried to find it but I couldn't 'forget' the password like I can do on my phone or laptop. I ended up factory resetting the 'google home' speaker and now I am not able to pair it again on the existing network.

    Earlier today, I had actually reset my router to 'factory defaults' settings, and that did not help as well.

    I am considering buying a new router. I don't have any backup in the house to try that out.

  • HT_GreenfieldHT_Greenfield Posts: 67 Contributor
    Aug 21, 2022

    Hi there, @vikkee . If you're not a do-it-yourselfer, i'd recommended signing up for Spectrum's Wi-Fi service. I think it was $4.99/month the last time i'd heard. I think that includes the cost of the wireless router they provide. I'm sure it'd be the most fool-proof way to go with your Spectrum broadband Internet service.

    If you ARE a do-it-yourselfer, whether you buy a new router or not, i'd recommend connecting your laptop to one of your router's Ethernet switch ports and proceeding with the set-up process provided by the manufacturer. If you need help finding the documentation & support information for your router via the manufacturer's website, let us know & i should be able to lead you to it.

  • vikkeevikkee Posts: 5 Spectator
    Aug 22, 2022

    Thanks for the suggestion @HT_Greenfield! That is how I was able to complete the setup process, you are right. I like to think I am a DIYer, It's usually plug-and-play with basic steps and I am up and running.

    This new spectrum service is definitely unique and challenging. I keep getting re-directed to the "Spectrum Activation" page, so the router does have internet access but the ISP is blocking it.

    I have been using my personal router for almost 10 years now and have successfully used it with different ISPs (Verizon FIOS, Xfinity). Saved me hundreds of dollars in fees.

  • HT_GreenfieldHT_Greenfield Posts: 67 Contributor
    Aug 22, 2022

    The ISP is Spectrum & you said you can access the Internet fine directly from the Spectrum modem Ethernet port so it doesn't sound like the ISP is actually blocking much if anything, @vikkee . What happens with that Spectrum Activation page? Are you able to "activate" anything, per se? Regardless, if you're still having problems with the router, i'd connect the laptop to one of its Ethernet switch ports & hard reset it & proceed with the prescribed setup process. Let me know if you don't know what i mean by "hard reset." It doesn't have anything to do with any power interruption.

  • vikkeevikkee Posts: 5 Spectator
    edited August 23 Aug 23, 2022

    Thanks for staying with me @HT_Greenfield, appreciate your responses.

    That is correct, if hard-wired connection works, case closed. I have zero say.

    But what if the only website that works is spectrum.net? Doesn't it indicate the traffic is somewhat being blocked or re-directed by the ISP?

    I tried your idea of hard-resetting of router, but it did not help. It's a great idea btw, I had not tried that yet. It still redirects to activate.spectrum.net. I proceed and login, it gives a "Fiber is active" message. No other websites work.


    Spectrum couldn't help me so I was hoping to hear new ideas here from the community members' personal experiences!

    I have another T-Mobile 5G Home Internet device here, and my router works just fine with that device. Simple plug-and-play, and no surprises. It's been the case so far with the different ISPs I had.

    Spectrum does not recognize the traffic coming out of this router for some reason.

  • HT_GreenfieldHT_Greenfield Posts: 67 Contributor
    Aug 23, 2022

    OK @vikkee . If you’ve not already done so, you might want to connect the laptop directly to the modem via Ethernet & log in to your Spectrum account & send a reset packet to the modem & see if that ends up fixing anything. I suppose the modem could somehow be mis-detecting the router as a Spectrum router that needs to be activated or is somehow otherwise invalid, but that’s pretty far-fetched & something i’ve never heard of. Ultimately you might need to call Spectrum & find out if they want to send a tech over or replace the modem or both. 

    If anybody in this community has any experience with this specific issue, i sure hope they drop in & share their knowledge. Good luck! 

This discussion has been closed.