Before posting a new question, please check out our Internet / WiFi and Spectrum TV App troubleshooting pages for common issues, as well as useful information to include in your post.

Advanced Search Options


We have advanced search options to make it easier to locate posts, questions and answers on this community.
More information can be found at Advanced Search Options
If you are looking for something specific, please check if someone else has already asked or answered the same question.

Unable to connect to internet via Xbox One

frustrateduser_88frustrateduser_88 Posts: 3 Spectator
edited September 22 in Connectivity Aug 22, 2022

I keep getting a Teredo error and can't connect to the internet at all on my Xbox One. I believe I need to open some ports or forward some ports on the router but the app won't allow it and keeps giving an error. Also tech support is not assisting at all and said they can't do it or give out the IP address so I can. The router is a spectrum router. Can anyone assist?

Replies

  • Steph_SSteph_S Posts: 442 Moderator
    Aug 22, 2022

    Hello and welcome to our community.


    Can you please follow these steps:

    1. Press Windows + I to open Settings app.
    2. Go to Gaming > Xbox Networking.
    3. In the right-pane, make sure the Internet connection is connected under Connection Status.
    4. Under Xbox Live multiplayer section, click Fix it button to fix the Teredo IP address issue. Then, click Check again button to try reconnecting.

    Please reboot the modem/router and test the connection. If you continue to experience trouble, please let me know.

  • frustrateduser_88frustrateduser_88 Posts: 3 Spectator
    Aug 22, 2022

    I looked on my laptop and my Xbox and the instructions don't follow the settings apps. I know this is usually fixed by forwarding ports or opening ports. That's how I fixed it in the last place I lived. Can this be done in the Xbox settings screen? The strange part is that when I run the Test Network Connection it says I'm connected but my NAT type is unavailable and I am clearly not connected, or being blocked by the Teredo issue.

  • frustrateduser_88frustrateduser_88 Posts: 3 Spectator
    Aug 22, 2022

    Spectrum won't let me access my router to enter info, which again is how I fixed it last time. And they won't enter it for me and the app doesn't work either. It has a section to do it but keeps giving an error saying it can't be done at this time, try again later.

  • HT_GreenfieldHT_Greenfield Posts: 67 Contributor
    Aug 23, 2022

    Teredo is just a protocol. It doesn’t block anything, per se. It’s just that some multiplayer games & services call for it. Regardless, if you need it, your best bet would be a router that supports enabling open NAT - if not the Teredo protocol itself - so you wouldn’t have to massage port & protocol settings. How you get there is between you & Spectrum.

    https://support.xbox.com/en-GB/help/Hardware-Network/connect-network/xbox-one-nat-error#troubleshooting-specific-nat-errors

  • RAIST5150RAIST5150 Posts: 868 Contributor
    Aug 23, 2022

    Does the XB1 have settings controlling UPnP? Or can you access such options for the router?

    Provided it is active on both ends, it should auto negotiate opening/forwarding ports for you.

This discussion has been closed.