Before posting a new question, please check out our Internet / WiFi and Spectrum TV App troubleshooting pages for common issues, as well as useful information to include in your post.

Advanced Search Options


We have advanced search options to make it easier to locate posts, questions and answers on this community.
More information can be found at Advanced Search Options
If you are looking for something specific, please check if someone else has already asked or answered the same question.

Frequently Asked Questions


(Quick links to the current most searched topics)
How can I pause and rewind live TV using the Spectrum TV app?
Spectrum TV App Supported Devices

2 Xbox Series (X & S) are being kicked from Multiplayer Lobbies on my home network. What can I do?

Ashley0729Ashley0729 Posts: 2 Spectator
edited November 8 in Connectivity Sep 28, 2022

So, my Xbox's on my Spectrum network keep kicking me out of in-game lobbies with the error "unable to connect to host". This is happening across multiple games, so it's not a game issue. I've spent an entire day on the phone with Xbox, Spectrum and ASUS (they make my router, RT-AX88U). So, here's everything I've tried:

  • Changed Xbox DNS to Google's
  • Cleared and reset Xbox MAC Address
  • Changed Ports
  • Changed Ethernet Cords and LAN ports
  • Tried using wireless
  • Factory Reset and Power Cycled Xbox
  • Factory Reset router
  • Bought a NEW router (Nighthawk RAX43, then returned. Still using RT-AX88U)
  • (No packet loss, ethernet & strong wireless connection, Open NAT)

Download speeds are as expected, and there are no other connection issues apparent. All other Xbox services are working, and all other devices are working as expected.

Spectrum said they can't help, ASUS said they can't help, Xbox has no idea and just wants me to send my Xbox's in for repair.

It is NOT a hardware issue, as both Xbox's have the same issue, all under the same troubleshooting. That's why I believe it's a network issue and am asking here. If anyone has any ideas or is familiar with the ASUS Router app or routerlogin.net interface, please let me know what to do.

Thank you!

Accepted Answers

  • Tyleen_ZTyleen_Z Posts: 513 Moderator
    Sep 29, 2022 Answer ✓

    Hello and welcome to the Spectrum community.

    Generally speaking if the issue is only affecting one part of one type of device it is not a network issue.

    Have you tried to bypass the router and hard wire either of the Xbox's in to the modem directly?

    -Tyleen

  • HT_GreenfieldHT_Greenfield Posts: 139 Contributor
    edited September 29 Sep 29, 2022 Answer ✓

    Not really my bag but it just seems like not all peers are always all that equal with some of those P2P hosts, especially the turkeys that aren't very much beholden to Microsoft or anybody else. So I'd check their support sites & user forums about this, if you haven't already done so.

Replies

  • Ashley0729Ashley0729 Posts: 2 Spectator
    edited September 29 Sep 29, 2022

    Hello Tyleen,

    While it is only one kind of service, it's the only service of it's kind across two devices on the same network.

    It doesn't make sense that two separate units of different kinds are encountering the same issue, the only constant is the network.

    I have not attempted that, but I can, and hope that it fixes the issue.

    And yes, I have scoured the Microsoft Forums and had to post my own question (which has yet to provide any help), as well as contacted their support directly as well as community support.

    I love that the only advice from everyone is "contact the other party".

  • RAIST5150RAIST5150 Posts: 871 Contributor
    edited October 10 Oct 10, 2022

    Just because I didn't see it specifically mentioned, is UPnP enabled on the router, or are you setting them manually (best to only do one or the other, not both).

    Generally, that is the issue in these scenarios... something is preventing the inbound traffic from forwarding to the internal IP from the outside (P2P stuff).

    Not sure about the netgear GUI, but Asus usually has a way to see what ports are actually getting opened and forwarded. Think it was where you can view the logs... been a while since I looked at it. It can also be checked from a Windows box if Network Discovery is working properly by viewing properties of the router in your network section of Explorer.

This discussion has been closed.