Before posting a new question, please check out our Internet / WiFi and Spectrum TV App troubleshooting pages for common issues, as well as useful information to include in your post.

Advanced Search Options


We have advanced search options to make it easier to locate posts, questions and answers on this community.
More information can be found at Advanced Search Options
If you are looking for something specific, please check if someone else has already asked or answered the same question.

Frequently Asked Questions


(Quick links to the current most searched topics)
How can I pause and rewind live TV using the Spectrum TV app?
Spectrum TV App Supported Devices

My Spectrum app 10.20.0 crashes (10.19.0 works fine); waiting for 10.21.0

SjacksSjacks Posts: 2 Spectator
edited November 1 in Troubleshooting the My Spectrum App Oct 26, 2022

It Crashes after I updated from 10.19.0 to 10.20.0 on Samsung Galaxy S*. Clearing cache/data doesn't fix; neither does uninstall/reinstall or changing browser from Brave (which worked w/ 10.19.0) to either Samsung Internet or Chrome. Google Play Store should provide access to one or two PRIOR versions of these Apps to regain functionality! Changed back to 10.19.0 fixed problem instantly. There's no point in updating again until 10.21.0 comes out.

😣

Tagged:

Replies

  • James_MJames_M Posts: 3,772 ADMIN
    edited October 27 Oct 27, 2022

    Sorry for the issues you are having with the app. Do you have a different device you can use to test the app again? If not, can you try launching the app again and reply with the date and time the app crashed (as exact as possible) so we can forward this information to the app team for further investigation?

    Thanks!

  • weinbersweinbers Posts: 3 Spectator
    Nov 03, 2022

    Same problem with 10.21.0. On 2 different android devices, app just spins and never loads anything after the splash screen (just displays app title)..

  • Paul_BPaul_B Posts: 575 Moderator
    Nov 03, 2022

    Hello @weinbers and welcome to the Spectrum community!

    I am sorry to hear that you're having problems with the app. Have you tried to completely uninstall the app and re-install it to see if that changes anything for you at all?

    Paul_B

  • weinbersweinbers Posts: 3 Spectator
    Nov 03, 2022

    Yes, on both (one android 13, the other 12). No difference...

  • Paul_BPaul_B Posts: 575 Moderator
    Nov 03, 2022

    When this happens, the other thing you can try is to reboot your modem and router by unplugging them for about 30 seconds and plugging them back in. Our apps are very heavily reliant on the modem and router and a lot of times doing a reboot will resolve an issue such as this.

    Paul_B

  • weinbersweinbers Posts: 3 Spectator
    Nov 03, 2022

    I turned off wifi on my phone and via 5g, was able to get the app going and it works now on wifi. My tablet is wifi only, but the app finally initialized and I could log in via wifi once my phone was working... No need to reset router or modem.

  • SjacksSjacks Posts: 2 Spectator
    Nov 04, 2022

    I downloaded/installed 10.21.0 and it works without any issues (like 10.19.0 did) on my Samsung Galaxy S7 which has Android version 8..0.0., ___ I wonder if Charter Spectrum can inform me what was changed between 10.19.0 (which worked) and 10.20.0 (which did Not work) and 10.21.0 (which works)?

Sign In or Register to comment.