Before posting a new question, please check out our Internet / WiFi and Spectrum TV App troubleshooting pages for common issues, as well as useful information to include in your post.

Advanced Search Options

We have advanced search options to make it easier to locate posts, questions and answers on this community.
More information can be found at Advanced Search Options
If you are looking for something specific, please check if someone else has already asked or answered the same question.

Frequently Asked Questions

(Quick links to the current most searched topics)
How can I pause and rewind live TV using the Spectrum TV app?
Spectrum TV App Supported Devices

Access to app settings crashes app on Roku.

clavinc2clavinc2 Posts: 5 Spectator

I have two ROKU express units that I use to receive

Spectrum TV. Models 3710X and 3900X.

For the past year, when I am in the spectrum app, and I click the

settings icon, The app crashes and reverts back to the ROKU menu.

Everything else on the app works fine.

I have replaced the router, replaced the ROKU with a new

unit, done several factory resets and the problem persists.

The last thing I did yesterday, was do a factory reset, log on

to a completely different network (Using a cellphone), used

a completely different account, and problem is still there.


  • James_MJames_M Posts: 3,953 ADMIN
    Dec 27, 2022

    Hi & welcome!

    Sorry for any issue with the app. Have you also tried a Roku reset from the settings menu? It may help to also clear your history on the app as well as delete and reinstall the app. For more information, here is a link: Spectrum TV for Roku: Getting Started

  • clavinc2clavinc2 Posts: 5 Spectator
    Dec 27, 2022

    I already put a new ROKU in plus I did a factory restart every time

    I changed something.. New ROKU plus new network plus new account. The network was

    thru a cellphone, completely bypassing the MODEM, Router and Network

    I don't have enough fingers to count all the factory resets I did, plus the problem is

    on both ROKUS on separate TV sets.

    What else is there?

  • James_MJames_M Posts: 3,953 ADMIN
    Dec 27, 2022

    Rokus can be sensitive, especially if they are used regularly. Clearing the history and resetting from the settings menu usually resolves most issues. Please give these steps a try and let us know if it helps.

  • clavinc2clavinc2 Posts: 5 Spectator
    Dec 27, 2022

    I'm sorry. We are not on the same page.

    I have to go thru the settings in order to do a factory

    reset. If I do a factory reset, that clears everything, and

    the ROKU has to update from scratch.

    This seems to be a problem only with the Spectrum app.

    It is the only item that I can't change..

  • James_MJames_M Posts: 3,953 ADMIN
    Dec 27, 2022

    Are you also seeing an error code when this happens?

  • clavinc2clavinc2 Posts: 5 Spectator
    edited December 2022 Dec 28, 2022

    No. It just goes dimm for a few seconds and to the ROKU menu.

  • James_MJames_M Posts: 3,953 ADMIN
    Dec 28, 2022

    From the Roku support page How to system restart or factory reset your Roku streaming device, a factory reset will "clear the majority of data from your Roku device and restores it to a factory default configuration".

    Since you have needed to reset the devices several times, there may be an issue with the devices themselves. You can try other steps, such as swapping the HDMI cord. Also, please check to make sure the Rokus have updated, since a factory reset restores the default configuration, you will likely need to make sure the Roku is updated, especially if it is an older device. Last suggestion to try and replicate the issue on a new or different device.


  • clavinc2clavinc2 Posts: 5 Spectator
    Dec 28, 2022

    It has to be my location. I took my ROKU to another area and used

    another Spectrum internet connection. Everything worked.

    I brought it back and everything still worked.

    All I have to do now is take my other ROKU to the other location and

    set it up. As long as I don't remove the Spectrum app, it should

    keep on working.

    Hell of a way to fix it, but it did work...

This discussion has been closed.