IPv6 and Apple Music slowdowns?

Options
Saltgrass
Saltgrass Posts: 124 Contributor
edited September 2023 in Internet 2023 Archive

Recently, I subscribed to Apple Music. I had a trial period of 5 months and iTunes worked fine. After I started the subscription, iTunes, and Apple Music, slowed to a crawl where playing music or any type of downloads would take maybe 5-10 minutes. Just populating its 4 sections would not populate, except for the local music library. But the Local Library would play music normally, if previously downloaded.

I discovered I could disable IPv6 and the performance would return to normal.

I read Apple likes to use IPv6 with a Stateful instead of Stateless which Spectrum uses. I will assume, for the time being, this situation is causing the slow downs because the IPv6 was trying to connect and keeping from the IPv4 from taking over.

So, I am wondering if I am correct in what I believe and if so, does Spectrum plan on addressing this situation? I have reported this to Apple Music but they probably were already aware.

Thanks for reading.

Answers

  • Lyn_T
    Lyn_T Posts: 453 ✅ Verified Employee Moderator
    Options

    Good evening @Saltgrass

    Thank you for reaching out to us about the concerns you are experiencing with Apple Music. I have checked and I am not seeing any known concerns at this time. Are you able to disconnect from the internet with your mobile phone to see if you are still noticing this? Is this happening with all devices or just one device?

    -Lyn

  • Saltgrass
    Saltgrass Posts: 124 Contributor
    Options

    I have a Windows 11 Desktop system involved. The iPhone is normal but I don't know if it uses IPv6.

    I have confirmation from another user on the Apple community of this situation.

    I assume I have to use the IPv6 settings Spectrum requires.


    Connection type Native

    DHCP-PD Enabled

    Auto Configuration Stateless

    IPv6 DNS Enable

    Enable Router Advertisement Enable

    Thanks for the response.

  • Saltgrass
    Saltgrass Posts: 124 Contributor
    Options

    I found a workaround. It seems Windows favors IPv6 over IPv4 but there is a way to change that. It is a Registry change for Advanced Users, as the link implies.

    Go to the site below and follow the instructions for giving IPv4 priority over IPv6

    Configure IPv6 for advanced users - Windows Server | Microsoft Learn

    If you follow the instructions, I suggest you make note of the process so you can reverse it in the future, if that becomes necessary.

This discussion has been closed.