Start up channel issue with Roku

Options
Magicman52
Magicman52 Posts: 20 Participant

One of my Roku devices does not go to the start up channel. The device is plugged into an electrical outlet, not the TV USB. A restart allows the startup channel. Is there another way to clear the device and allow the startup channel every time I turn on the TV?

Best Answer

  • Lyn_T
    Lyn_T Posts: 412 ✅ Verified Employee Moderator
    Answer ✓
    Options

    Good evening @Magicman52

    Thank you for reaching out to us about your Roku device. Have you attempted to uninstall the App and reinstall the App yet? If this doesn't help out please let us know. -Lyn

Answers

  • Magicman52
    Magicman52 Posts: 20 Participant
    Options

    After removing and reinstalling the App, it looks like that resolved the start-up channel issue. I will continue to check and will reply if the issue resurfaces. Thank you for the suggestion.

  • Magicman52
    Magicman52 Posts: 20 Participant
    Options

    I need to write back, that the fix by removing and reinstalling the Spectrum App was short lived. When I used the TV in question this morning, it remained on the last channel from last evening. I did check and my start up channel is listed and correct. This seems to be happening only on a specific TV using a Roku stick.

  • James_M
    James_M Posts: 4,770 ✅ Verified Employee Moderator
    Options

    Thanks for the update. Can you also try restarting the Roku from the settings menu? Restarting the device usually resolves most issues.

  • Magicman52
    Magicman52 Posts: 20 Participant
    Options

    I will try this latest suggestion and respond back tomorrow with comments. Thank you.

  • Magicman52
    Magicman52 Posts: 20 Participant
    Options

    The latest suggestion to restart the Roku from the Roku settings menu did not work. The TV was off for 8 hours overnight. The Spectrum App started with the last channel watched, not the listed startup channel. Are there any more suggestions?

  • HT_Greenfield
    HT_Greenfield Posts: 736 Contributor
    edited July 2023
    Options

    It sounds like that all may be exactly by Roku design:

    🔗https://www.cloudwards.net/how-to-turn-off-roku/

    Rokus are designed to stay on. Some Roku remotes have a power button but that is only to turn the TV on/off (presumably via HDMI CEC). If you want the Roku to turn off when you turn off the TV, you supposedly can do so if the Roku is powered via TV USB but you can't turn the TV on via HDMI CEC from an unpowered device.

  • Magicman52
    Magicman52 Posts: 20 Participant
    Options

    I went to plugging in my Roku to stop the jumping Roku start up each time. Again, this problem is only from one Roku stick. I will just manually change the channel instead of purchasing another stick.

    I appreciate all the suggestions and think this will close out my inquiry.

    Thanks.

  • HT_Greenfield
    HT_Greenfield Posts: 736 Contributor
    Options

    So whenever you start up the app - whether that's after powering the device down and back up again or after closing out the the app and starting it back up again - it doesn't go to the startup channel? Just curious.

  • Magicman52
    Magicman52 Posts: 20 Participant
    Options

    Correct. I’m guessing it’s an issue with the software of the stick. It only happens on this unit. I’m not aware of any other method to clear the stick to factory reset.

  • HT_Greenfield
    HT_Greenfield Posts: 736 Contributor
    Options

    🔗https://support.roku.com/article/208757008 : ↳ Factory reset your device

  • Magicman52
    Magicman52 Posts: 20 Participant
    Options

    I will try the factory reset when I return from vacation. Thanks.

  • Magicman52
    Magicman52 Posts: 20 Participant
    Options

    I tried the response to do a factory reset on my Roku stick. I followed all instructions on the screen. Unfortunately, even the factory reset did not change the outcome. It still starts on the last channel instead of the requested start up channel.

  • James_M
    James_M Posts: 4,770 ✅ Verified Employee Moderator
    Options

    Thanks. What is the model of the Roku stick you are using?

  • Magicman52
    Magicman52 Posts: 20 Participant
    Options

    Hello,

    3810X - Roku Streaming Stick+

    Software version 12.0.0 - build 4184-50

    i hope this helps!

  • James_M
    James_M Posts: 4,770 ✅ Verified Employee Moderator
    edited August 2023
    Options

    In addition to the factory reset, can you try restarting the modem and also deleting and reinstalling the app again?

    The modem was last restarted just over a week ago and the app was updated since the last time you reinstalled the app. Hopefully these extra steps will resolve the issue.

  • Magicman52
    Magicman52 Posts: 20 Participant
    Options

    I did the app deletion previously. I will try the modem reboot later this evening. My confidence level is dropping after every proposed solution.

    My major question is why is this only happening on one Roku and not any of my other Roku’s?

  • Magicman52
    Magicman52 Posts: 20 Participant
    Options

    The reboot of the modem made no difference. I have included a picture of the start up station screen.


  • James_M
    James_M Posts: 4,770 ✅ Verified Employee Moderator
    Options

    Thanks. Since the issue is occuring with only one device, that make me think there is an issue with the Roku device itself. They do have a tendency to overheat, so if it feels warms or hot, try unplugging it until the next use. We have gone through all the standard troubleshooting for Roku and I've included a link to our Roku support page for future reference.

    Next, I would suggest contacting Roku support to see if they have suggestions. Unfortunately, it does sound like it may be the device itself and it is possible that the device needs to be replaced.

    Sorry we could not be of more assistance with this issue.

  • Magicman52
    Magicman52 Posts: 20 Participant
    Options

    I am in agreement with you that it appears to be the device. I want to thank you and the other folks that worked to find a resolution. I will continue to change to the start up channel manually.

This discussion has been closed.