Can't send emails

Options
tbusr
tbusr Posts: 3 Spectator
edited January 10 in Internet 2023 Archive

I can no longer send emails from my desktop. The original error said "The email address you are sending as must match the email address you used to auth". I tried changing the authentication settings for outgoing and it now fails with a "TLS Handshake failure". My settings match those shown on Spectrum. I talked to support and they said as long as the email works on their website, they can't help. In reviewing the posts here I see this is a very common problem. The majority of the latest posts have to do with this failure and they all end without a fix. Can anyone suggest what I should do?

Best Answer

  • tbusr
    tbusr Posts: 3 Spectator
    Answer ✓
    Options

    I've been going through all the FAQ's and found one that said the server should be mail.brighthouse.com. I tried that and it worked. Unbelievable! It's bad enough they would make a change like this without sending a notification, but I was on the phone with support this morning for almost an hour and support never mentioned it.

    Thank your your help James.

Answers

  • James_M
    James_M Posts: 4,777 ✅ Verified Employee Moderator
    Options

    Hi & welcome!

    Sounds like you already tested on Spectrum Webmail and can access email. Which email client are you using when you get the error?

  • tbusr
    tbusr Posts: 3 Spectator
    Options

    I'm using The Bat. I just installed Thunderbird since it has automatic setup so I thought it would be worth a try. It picked up the server as mobile.charter.net, which is not correct as I understand it. For the outgoing server I've always used smtp-server.mi.rr.com.

    But I tried changing the server entries in both programs to mobile.charter.net. The result is the same for each program. The incoming only works if I use pop-server.mi.rr.com. The outgoing fails no matter what the server is set to. However, using mobile.charter.net gets past the handshake problem. With that name, it fails authentication. So, maybe, this is a step in the right direction.

    In case it helps, I have the ports set to 993 and 587 and TLS enabled. But I tried it with non-secure pop port numbers. These settings don't seem to make any difference with regards to this problem since the failure is same either way.

  • James_M
    James_M Posts: 4,777 ✅ Verified Employee Moderator
    Options

    Thanks for the update, glad to hear you found a solution! You are correct, legacy Brighthouse would want to use the Brighthouse server (and legacy TWC uses the TWC server). I added your comment as an answer, hopefully it will help someone else with a simialr issue.

  • Kiro
    Kiro Posts: 1 Newcomer
    edited August 2023
    Options

    Same issue. I'm on nycap.rr.com and sending email via Outlook 2013.

    Was working July 2023.

    Ask-Spectrum says: not our fault. However, multiple help forums showing multiple questions / problems with same description "Can receive ok but cannot send from Outlook". Same message: "The email address you are sending as must match the email address you used to auth".

    Seems to be a common problem.

    Similar send-email problems back in March 2022 with Spectrum acknowledging they had a known issue.

    To Spectrum: If this is similar issue, hey, no problem but please let your helpdesk (ask-spectrum) know so they can communicate appropriately.

    I'll keep watching this thread to see if Spectrum posts an update.

    Thanks

  • HT_Greenfield
    HT_Greenfield Posts: 739 Contributor
    edited August 2023
    Options

    @Kiro : i think you'll need to change the server hostname to mail.twc.com and the User name to one and the same as your full email address rather than just the id. part thereof, in the Outook account settings and then from there into advanced settings, make sure that the outgoing server encryption protocol is either "TLS" or "TLS/SSL" or "SSL/TLS" rather than just "SSL" and that the port number is 587. If you're using POP3 don't change that to IMAP unless/until you understand the ramifications and also probably no need to change any of the incoming advanced settings as long as incoming is working fine.

    🔗https://www.spectrum.net/support/internet/outlook-2010-setup-chtr

    🔗https://www.spectrum.net/support/internet/mobile-email-setup

This discussion has been closed.