Epson printer not connecting via wifi

Shafiq
Shafiq Posts: 3 Spectator

Spectrum just installed a new router and now the Epson printer shows connected but in the spectrum app showing IP blank and host name as unknown

I have tried giving the printer a static up but still no success

connecting via Ethernet cable is not an option

thx

Answers

  • Lyn_T
    Lyn_T Posts: 200 Moderator

    Good evening @Shafiq and Welcome to our Community Forums

    Thank you for reaching out to us about connecting your printer to your WIFi. I recommend deleting/forgetting the WiFI connection on your printer and then resetting the WiFi back up to your printer. To learn more about connecting your WiFi services to your network click on the link. -Lyn

  • Shafiq
    Shafiq Posts: 3 Spectator

    Hi @Lyn_T

    i did remove and then reattach the printer.

    still same result as before.

    i “think” the issue might be with the security protocol. My printer is WPA-PSK (AES)

    and the new routers do not support legacy protocols.

    If thus is true - is there a workaround?

    thx

  • Shafiq
    Shafiq Posts: 3 Spectator

    By remove and reattach I mean I did disconnect the printer by pausing and unpausing from the network

  • HT_Greenfield
    HT_Greenfield Posts: 454 Contributor

    If it says AES instead of TKIP, then it's WPA2, regardless, which goes right along with where the advanced home Wi-Fi router is at, like you say, and the old hulk would have to be older than some of the stuff in my freezer to not do WPA2. What model is the old hulk and can you at least temporarily connect it to the router via Ethernet just to make sure it's TCP/IP stacking siliconics are still stacking up, per se, just for kicks?