Recordings on the Spectrum TV App not deleting in My Library

vfrett
vfrett Posts: 11 Participant
edited November 2023 in Cloud DVR

I have 3 SAMSUNG TVs and I am using the Spectrum TV app with Cloud DVR. For the past couple of weeks I noticed that when I record a tv program it does not display in the My Library section until I exit the TV App. Once the program shows in the My Library Section and I delete it, it says it deleted but the program's ICON still remains in the My Library section until I exit the TV App. Additionally the Spectrum TV app works well on all other devices. Programs record and delete without issues. I called Spectrum and Samsung about this issue. Spectrum advised me to replace my Modem and Router which I did but the issue is still there. Spectrum advised me to speak to Samsung which I did and Samsung said it was a Spectrum TV app issue. I also tried reinstalling the TV App but the issue is still there. Here are some additional information.

Spectrum TV app version is v30.10.1 and the Samsung TV version is 1520.7

Best Answer

  • Ruben_R
    Ruben_R Posts: 55 ✅ Verified Employee Moderator
    Answer ✓

    I do apologize for this inconvenience. Are there any other devices with the app that are open at the same time?

Answers

  • vfrett
    vfrett Posts: 11 Participant

    Yes. I have any Samsung TV that is sometimes on at the same time.

  • vfrett
    vfrett Posts: 11 Participant

    Also most times only on TV is on at a time.

  • James_M
    James_M Posts: 4,514 ✅ Verified Employee Moderator

    Thanks! Next time you delete a program, can you make sure the other TV's or devices have the app closed, then try deleting the program from your library and let us know if the issue continues. You may also need to restart the TV(s) to reset and clear the history.

  • vfrett
    vfrett Posts: 11 Participant

    Hey James. I tried it with only 1 TV on and recorded a program. It does not show in the My Library Section but if you click on the VIEW DVR it show there. I turned the TV off and back on and now it shows in the My Library Section. I tried deleting the program but the programs Icon is still in the My Library section.

  • James_M
    James_M Posts: 4,514 ✅ Verified Employee Moderator

    Do you have another device, maybe a tablet or smart phone, that you can use to test and see if you see the same thing?

  • vfrett
    vfrett Posts: 11 Participant

    All other devices IPADS and phone operate correctly. The problem is only on my 3 Samsung TV

  • James_M
    James_M Posts: 4,514 ✅ Verified Employee Moderator
    edited September 2023

    Thanks. We are not seeing any known issues or similar reports from other users specific to Samsung TV's. If you try managing your library from one of the other devices, does it display correctly on the Samsung TV?

  • vfrett
    vfrett Posts: 11 Participant

    No it does not. I am recording an episode using the app on my cell phone. It shows in the DVR section on my phone but it does not display in the My Library section on my TV. If I go to the VIEW DVR under the My Library Section and click on the VIEW DVR the recorded program show up there.

  • vfrett
    vfrett Posts: 11 Participant

    I will have to exit the Spectrum app on my TV to see the recorded program in the My Library Section. Once it is there if I delete it either from the VIEW DVR Section or the My Library section the programs ICON remains until I exit the application.

  • James_M
    James_M Posts: 4,514 ✅ Verified Employee Moderator

    Thanks. Since the app is working correctly on other devices and there are no known issues, it does appear to be an issue specific to the Samsung TVs. We are not seeing any similar reports from other users and I was unable to replicate on our Samsung TV we use for testing. At this point, I would suggest reaching out to Samsung Support to see what they recommend for your specific TV model. Please keep us updated!

  • vfrett
    vfrett Posts: 11 Participant

    Hey James. I reached out to Samsung already and they stated that they do not have control of APPs on the tv. They just host the apps. So no joy on that. Is there a way I can share a video of what is happening to you so you can see what I am talking about?

  • James_M
    James_M Posts: 4,514 ✅ Verified Employee Moderator

    You can add screen shots and photos. For video, you would need to use a third party site, such as imgur and imbed the URL. However, it does sound like an issue with the TV and not the app. There may be a setting that is causing the app to not respond correctly. We are unable to support the TV itself, so the suggestion to contact Samsung again was to check settings and determine if a reset would help. Will keep an eye out for the video link.

    Thanks!

  • vfrett
    vfrett Posts: 11 Participant

    Hey James. I would like to add that it is happening on 3 Samsung TVs different models and different versions. If it was TV I would say it was the TV. It is happening on 3 different Samsung TVs.

  • vfrett
    vfrett Posts: 11 Participant

    James. I just spent an hour with Spectrum and used a video link and showed the Tech what was going on. Once we got to the Cloud DVR area where the issue exist the Samsung Tech stated that it was no longer a TV issue but an APP issue. I just did a reset on the Smart Hub on the TV and reinstalled the Spectrum APP and but the issue is still there.

  • vfrett
    vfrett Posts: 11 Participant

    Sorry James I meant I spent an hour with the Samsung Rep

  • LisaR
    LisaR Posts: 1 Newcomer

    I would like to say that I have had the same issue as vfrett for about 10 days. I’ve contacted Spectrum and after going through all their steps I was told 5 days ago that my issue was escalated to the Engineering Department and they would contact me in approximately 48-72 hours. i have not heard from them yet.

    I also have done all the steps mentioned above and nothing has been resolved.

  • Lrm77
    Lrm77 Posts: 4 Spectator

    I also have a 2 Samsung TV’s with same problem. I turn off tv to get my library to update. This started to happen only after Spectrum (not Samsung) updated their mobile app, which I personally don’t like but that’s not what we are talking about! I have uninstalled the app, unplugged tv, modem, router for 10 minutes to allow everything to reset. Reinstalled the app and nothing has changed. I have max, Netflix, prime video, peacock, Hulu and none of my other apps are having any problem. I even did a 7 day trial of YouTube tv and no problem. This is a spectrum app problem. What about trying to rollback the app update and see if that will fix the TV app? Im sure there’s just something in the code causing it and agree unless you guys can reproduce hard to debug. I’m starting to look around and rethink, do I really need spectrum TV? I probably don’t but would miss it, but I’m almost ready to pull plug to TV app. I can watch everything I record on the other services I have, just a day later. Still love my internet service!

  • Lrm77
    Lrm77 Posts: 4 Spectator

    Also I’ve been trying to Google this problem for about a month and this is only the first post I’ve come across that shows someone else having a problem and I haven’t called tech support at all since I’m in IT I kinda know there’s nothing they can do. That’s why I’m saying it’s something in the new app code. Are they clearing out the cache and reloading the library screen after a delete is preformed? Are they reloading the library every time we exit our current screen to go back to the library screen? I know that’s using resources but rather have it work and wait 5-30 seconds for updated list then having to exit/turn off tv. Just a couple places to start looking.

  • Lrm77
    Lrm77 Posts: 4 Spectator

    @James_M any updates from tech support?

This discussion has been closed.