How do I keep the network alive between the WiFi router and a given IP address?

WehoCoder
WehoCoder Posts: 13 Participant
edited November 21 in Home Networking

This is a continuation to my prior question that has gone unresolved.

Canon says it's an issue with the router not keeping connectivity and/or swapping channels from 2.4ghz to 5g.

Spectrum says it's Canon's issue.

Why is this so difficult to keep a printer connection alive?

https://community.spectrum.net/discussion/172483/how-do-i-keep-the-network-alive-between-the-wifi-router-and-a-given-ip-address#latest

Answers

  • WehoCoder
    WehoCoder Posts: 13 Participant

    In chatting with support, this is their response:

    "Perhaps the issue is that the router puts the printer on the 5g channel and the printer then loses the connection. It might be better to get a router that allows you to choose the channel each device goes on.

    I just clicked on the button to optimize your network but I am not very hopeful that is a long term solution. If the router is changing the channel the printer is on, then it will continue to do so.

    I do know they are working on giving the routers that functionality but I don't know when that will be released. We are all waiting on it."

    So it appears Spectrum's "Advanced" WiFi router cannot handle WiFi printers?

  • William_M
    William_M Posts: 882 ✅ Verified Employee Moderator

    @WehoCoder

    Our router broadcasts both 2.4Ghz and 5Ghz networks under the same network name. It uses band steering to make sure your devices are on the best network for their location, which is usually 5Ghz when close but 2.4Ghz when further away. Switching between networks shouldn't cause a complete disconnect and that wouldn't explain why only the printer is having the issue.

    2.4Ghz is more prone to radio interference which is what running the network optimizer will help with by changing its broadcast channel, however interference typically will only cause brief pauses or speed issues. Channel adjustment is also only a temporary solution as over time all the other networks broadcasting in the area will change as well.

    Looking from my end it looks like your printer is just staying on 2.4Ghz with no band steering events at all, which actually concerns me as you mentioned the printer is only 2 feet away with 1 interior wall in-between. If your printer has a working 5Ghz adapter it should definitely be on 5Ghz. There could be something in the wall that is very dense or causing interference, and so you are using a 2.4Ghz signal being bounced the long way around, but I think a failing 5Ghz adapter in your printer is more likely and explains why rebooting the printer fixes the issue temporarily.

    I recommend setting up the printer in the same room to see if it switches to and stays on the 5Ghz, and if so if it works consistently like that. Other solutions would be to run an ethernet cable, or as Canon suggested get your own router that may be more compatible with that specific printer.

  • WehoCoder
    WehoCoder Posts: 13 Participant

    Thanks @William_M - My printer is a brand new model released this year. I checked the specs and this printer does not support 5Ghz. I was kind of surprised, but a quick google search shows that it is uncommon for WiFi printers to support 5Ghz. Upon reading why, it makes sense why WiFi printers would not need the 5Ghz adapter.

    Additionally, if you don't see that there are any band steering events on this device, then the 2.4Ghz vs 5Ghz is a non-issue anyway, correct?

    So now where does that leave us?

  • HT_Greenfield
    HT_Greenfield Posts: 539 Contributor

    Is it pingable or not when it idles out into that state and is the firmware up to date? V03.04 firmware for the thing came out just last month.

  • WehoCoder
    WehoCoder Posts: 13 Participant

    It is not pingable. At the same time the device shows with a green indicator on the Spectrum app.

    Yes the firmware is up to date.

  • HT_Greenfield
    HT_Greenfield Posts: 539 Contributor

    Whichever IP address it is that the router has currently assigned to the printer, reserve it and then restart the printer and cross your fingers:

    šŸ”—https://www.spectrum.net/support/internet/advanced-wifi-advanced-settings

    ā†³ Port Forwarding and IP Reservations

    Ref.: šŸ”—https://www.reddit.com/r/techsupport/comments/gh8wt7/canon_printer_wont_connect_but_its_connected/

  • WehoCoder
    WehoCoder Posts: 13 Participant
    edited October 20

    I've had it reserved as soon as I took it out of the box and hooked it up to the network, just 2 months ago.

  • HT_Greenfield
    HT_Greenfield Posts: 539 Contributor

    Not very helpful but i guess i'd disconnect the printer from the wireless router and use the printer's mobile device Direct Connection Wi-Fi instead or else replace the wireless router with a garden-variety one of my own or else replace the printer with one of a different product line or even brand.

    šŸ”—https://community.usa.canon.com/t5/Printer-Software-Networking/Canon-imageCLASS-MF632Cdw-connected-to-network-but-not/m-p/392350/highlight/true#M12445

  • WehoCoder
    WehoCoder Posts: 13 Participant

    Thanks for your input. If you have any recommendations on routers, I'd love to hear.

    Also if you have any suggestions on a printer that will work with the Spectrum Advanced WiFi Network, I'd love to hear.

    This is the reason I bought this new printer. I thought my old printer was broke so I went to get the latest and greatest technology available and tossed my old printer. Now I lost money from tossing my old printer when it was just a networking issue, and now I'm stuck with my brand new printer because I'm past the return window.

This discussion has been closed.