Can't see my device in the "Your Devices & Groups" list using the SAX1V1S router

Options
prevail
prevail Posts: 8 Spectator
edited December 2023 in Home Networking

I have an IoT device that is connected directly to the SAX1V1S router via an ethernet cable. The device has an IP address so I know that the router sees it and I am able to SSH to the device from a laptop.

The problem is that the device does not show up in the Your Devices & Groups list on the website or in the Spectrum mobile app. This is a big problem because I need to set up port forwarding and that requires being able to select the device from the list. I recently had the same IoT device connected to a different router from a different ISP and it showed up in the list of connected devices.

Unfortunately, Spectrum forces its customers to only be able to access to the router using the app or website. Logging into the router directly is not an option and I really don't understand why Spectrum does this.

Regardless, can someone from Spectrum help me with this? It has stopped me dead in my tracks.

Best Answer

  • William_M
    William_M Posts: 1,116 ✅ Verified Employee Moderator
    Answer ✓
    Options

    Hi @prevail, welcome to our community!

    Is that one device the only one not showing up? Have you tried rebooting the router, or maybe even factory resetting it? The devices and groups list should be the same as the routers client/assigned IP list.

    As far as why it is restricted, the large majority of our users have no need to set up port forwarding let alone change other settings in a router. Most who feel comfortable managing those settings are probably using their own router which you are welcome to do.

Answers

  • HT_Greenfield
    HT_Greenfield Posts: 735 Contributor
    Options

    Just curious if the IoT device is using a manually staked IP address that falls within the router's DHCP dynamic pool range of IP addresses.

  • prevail
    prevail Posts: 8 Spectator
    Options

    How would I determine if the device is using a manually staked address? So far the only address that I see for the device is the one that’s been assigned by the router and I assume that was assigned via DHCP.

  • HT_Greenfield
    HT_Greenfield Posts: 735 Contributor
    Options

    That's good. As long as DHCP remains enabled on the device (as it typically would be by default,) then manual couldn't be, which rules out the type of conflict i was worried about. You might as well "reserve" the device's IP address in DHCP on the router and then re-up the device's connectivity e.g. by power cycling it and see if it shows up, then, just for kicks. Otherwise just curious what kind and make and model the device is.

  • prevail
    prevail Posts: 8 Spectator
    Options

    I tried restarting, rebooting, pulling the plug, and everything else. Why not just offer a default "simple mode" where users are directed to the current interface that's available on the app and website, and an "advanced mode" where users can log into the router like they used to be able to do?

  • prevail
    prevail Posts: 8 Spectator
    Options

    How can I reserve the device's IP address in the router?

  • prevail
    prevail Posts: 8 Spectator
    Options

    Thanks but I don't see anything there about reserving an IP address in the router.

  • HT_Greenfield
    HT_Greenfield Posts: 735 Contributor
    Options

    Hit ↳ Port Forwarding and IP Reservations in there

  • prevail
    prevail Posts: 8 Spectator
    Options

    My device does not show up in the list of connected devices on the website or in the app. That's why I created this Post. If it did, I could set up the port forwarding that I need. Setting up IP Reservations also requires being able to choose a device from the same list.

    Unfortunately Spectrum has chosen to prevent direct access to the router via login, which was previously allowed. If they did, I could probably solve this. I don't suspect they're going to be much help with this besides the generic "reboot/reset" response.

  • HT_Greenfield
    HT_Greenfield Posts: 735 Contributor
    edited November 2023
    Options

    OK, my bad. I was assuming that the process would present active DHCP IP address leases and that the device's lease would show up there for you to go on even if it didn't show up as connected. If you can find a way anywhere in there, right there or e.g. some kind of a setup or LAN setup section. to just add or create a new reservation, all you need to know is the device's MAC address aka "hardware address" and the IP address you want to reserve for it e.g. the one it already has. Otherwise just curious what kind of a device it is and the make and model.

  • prevail
    prevail Posts: 8 Spectator
    Options

    "Otherwise just curious what kind of a device it is and make and model"

    https://wiki.friendlyelec.com/wiki/index.php/NanoPC-T6

    "If you can find a way anywhere in there, right there or e.g. some kind of a setup or LAN setup section"

    That's what I hope to find out - how can I access the router in spite of Spectrum's limitations? Actually this problem is on Spectrum's end because 1) I'm able to see the device when using Xfinity as the ISP and the router that they provide and 2) the device has an IP address, so the router is definitely seeing it which means it should appear in the list.

    If only Spectrum would ACTUALLY help me with this instead of marking my question as "Answered" just because a Spectrum employee simply responded...

  • HT_Greenfield
    HT_Greenfield Posts: 735 Contributor
    Options

    It seems obvious that the thing isn't getting its IP address from the wireless router's DHCP so i think it must be somehow hanging on to the IP address it got from the previous router. If there's no direct way to release and renew the IP address lease on thing, then try a factory reset or re-image it or, like William suggested, replace the router with one of your own. ☘️ I apologize to William and you, for my distraction.

  • prevail
    prevail Posts: 8 Spectator
    Options

    Actually I think it is getting its IP address from the router because the address has changed more than once after I reset the router.

    No need to apologize, you’ve been far more helpful that anyone from Spectrum.

This discussion has been closed.