Can't send emails

Options
rama
rama Posts: 1 Newcomer
edited January 10 in Internet 2023 Archive

SmtpConnectionInvalidResponsePermanentException: Server 'mail.twc.com' Port '587' returned invalid response. Check your SMTP server settings. --> Unexpected SMTP server response. Expected: 220, actual: 554, whole response: 554 p-impout003.msg.pkvw.co.charter.net cmsmtp 40.99.238.125 blocked. Please see https://www.spectrum.net/support/internet/understanding-email-error-codes for more information. AUP#Out-1130

 

Failure code: 66fc

Roadrunner account - on New outlook - on desktop

Answers

  • HT_Greenfield
    HT_Greenfield Posts: 767 Contributor
    Options

    I can confirm that IP address is lacking a reverse DNS pointer record and therefore isn't going to fly with too many outside spam-conscious SMTP services. It belongs to a massive intercontinental Microsoft Corp. ASN and in spot-checking several IP addresses across the vast swaths of IP address ranges and sub-ranges thereof, the absence of pointer records appears to be by design as in e.g. corporate privacy of some kind.

    🔗https://ipinfo.io/40.99.238.125

    🔗https://ipinfo.io/AS8075

  • Sidecar
    Sidecar Posts: 1 Newcomer
    Options

    I had a similar issue, in that I could receive email, but not send it, when using local Outlook or Thunderbird client. This did not affect webmail, where both receive and send worked fine. My address is a <region>.rr.com one.

    In Outlook's account setup tester, the following error message was returned: "Send test e-mail message: Your outgoing (SMTP) e-mail server has reported an internal error. If you continue to receive this message, contact your server administrator or Internet service provider (ISP). The server responded: 554 p-impout010.msg.pkvw.co.charter.net cmsmtp Connect." I did contact Spectrum tech support, but they never fail to disappoint.

    After more testing here, it seems that Spectrum checks outbound SMTP sender IP addresses against the Spamhaus ZEN blacklist of known/probable spammers. If you use a VPN, or another ISP besides Spectrum (for example, Lumos fiber), the IP address that the world sees may be on that blacklist. Presumably this is because these gateway addresses handle traffic from many users, both individuals and businesses, and the total volume of outbound SMTP traffic gets interpreted and flagged as spamming.

    Please note that the ISP may be concealing your "real" IP address behind a gateway to improve your privacy, but without your knowing. Check the address on your local router's WAN interface and compare it to the one that Speedtest, or similar site, reports. If you're having this email sending issue, it will probably be different.

    To check blacklisting, go to the MX Toolbox SuperTool site and search on that gateway address. If it's blacklisted by Spamhaus ZEN, that's the likely source of the problem.

    To resolve, the easiest thing is probably to use a VPN that does not assign you an address blocked through Spamhaus, though it may be blacklisted by other reputation sources. This involved testing several free VPN providers, but ultimately worked for me. MX Toolbox is your friend.

  • jrfk2
    jrfk2 Posts: 14 Participant
    Options

    I am getting the same response as well, as is my son

  • jrfk2
    jrfk2 Posts: 14 Participant
    Options

    See my post with the comment I marked as answered: How to set up the "new" MS Outlook for RR mail — Spectrum Community

This discussion has been closed.