iphone says router security is weak

Options
pete8703
pete8703 Posts: 2 Spectator
edited July 10 in Internet 2024 Archive

We are trying to hook up a new wireless speaker. My wife's iPhone Mini 13 says the router security is WEP. In my settings, it's WPA-2. How can I get this resolved?

Answers

  • HT_Greenfield
    HT_Greenfield Posts: 798 Contributor
    Options

    Change the wireless router security to include WPA2-PSK aka WPA2 Personal and to exclude WEP on both 2.4 and, if applicable, 5 GHz, even if you have to upgrade-replace the old hulk in order to do so. Then re-up the iPhone connection to it by deleting/forgetting it and then reconnecting and then go from there. Otherwise state the make and model of the old hulk as well as that of the speaker.

  • HT_Greenfield
    HT_Greenfield Posts: 798 Contributor
    Options

    Edit: My bad. Let me back up and start over by just asking for the make and model of the wireless speaker.

  • pete8703
    pete8703 Posts: 2 Spectator
    Options

    It's a Sonos Era 100.

  • HT_Greenfield
    HT_Greenfield Posts: 798 Contributor
    Options

    I don't think that speaker could have much to do with it so i'm guessing that you have WEP enabled on the router/AP 2.4-GHz service set but not the 5. You should be able to change that to WPA2 (or, less preferably but if needs be, WPA/WPA2.) Otherwise state the make and model of the router and post a screenshot of the security alert.

  • William_M
    William_M Posts: 1,196 ✅ Verified Employee Moderator
    Options

    Hi @pete8703, welcome to our community!

    Is the security alert coming from IOS or an app for the Sonos? Have you tried rebooting the iPhone and router?

This discussion has been closed.