Cannot use number pad or Right to change channel or Guide

Options

I just got my Xumo yesterday instead of the DTA and am VERY disappointed. For network television, everything I have read including YouTube videos shows pressing the right arrow to get the Guide with channel numbers, typing in the channel number and pressing the + to add a channel to My List. Instead, if I want to watch a show I have to go down 3 to “Guide View All” then Ok. Now scroll through the list (with no channel numbers) to find the program (you can filter a bit by choosing News, etc) then click Ok. Now it appears in a small window so I have to click Home then click on Currently Viewing to get it full screen.

That’s CRAZY!!!! The Spectrum app on Roku is simple and works like the videos and instructions. Am I doing something wrong? Thanks in advance for your advice.

Comments

  • PeteComp
    PeteComp Posts: 2 Spectator
    Options

    Update: I just set up my second Xumo and it worked fine. So, I did a Factory Reset on the first one and all (mostly) is good. Now I can press the Right Arrow to get the guide or use the number pad. MUCH better. One thing I still can't do, which is supposed to be a feature, is to have it default to the last channel used. Every time I turn it on, it defaults to Spectrum News. At least I can now type in a channel number and go to the channel I want.

    The other feature that doesn't work is the + sign to save to my Lists. I assumed if I turn to channel 13, let's say, then press the + sign, it should save it to my Lists, but nothing happens. In the Guide, I see a filter for Favorite Channels but can't figure out how to save a favorite channel.

    End result: much better than originally thought but still lacking features. Haven't tried all of the Apps yet but got an error using Plex saying that it is unable to stream my media. I'll stick with my Firestick for everything else other than local channels. I wish Spectrum would create an app for the Firestick, like they did for Roku, but then would not allow you to download it any more. Very frustrating!