Welcome to the Spectrum Community

Get answers, share solutions, help your community.

Start here

Spectrum TV App on Roku for authorized home-network channels opens and immediately closes

GhradGhrad Posts: 2
edited August 27 in Spectrum TV App 2019 Archive Aug 15, 2019

No connectivity issues . . . signal is excellent.  All streaming apps work flawlessly except Spectrum.  All was good for months and then all of a sudden last week, after opening the app on Roku and going to MSNBC, the channel would appear and immediately shut down.  Did lots of troubleshooting and discovered that Spectrum did not recognize or accept my sign-in as it would only allow me to view channels as though I was not connected to my home WiFi.  Reset Roku to factory standards, rebooted my internet modem/router, deleted and reinstalled Spectrum App and signed in.  Sometimes the "agree" button to terms would not take, while other times it would.  When such was accepted, I was able to view MSNBC.  However, after turning off Roku and TV, and then going back on, I was back to square one.  Only able to view stations as though I was away from home network.  Next, I called Spectrum for tech support.  Reported my issues and was not given any new instructions on how to resolve.  Customer service rep opened a ticket (sci000000212074) and said that I'd hear back.  Never heard back. The next evening, I open MSNBC and it worked.  The following morning, I did the same and it didnt work.  When viewing the channel guide, it appeared as though I was only authorized for non-home network viewing.  That evening, I tried again and it worked.  The next morning, it worked again.  It appears that Spectrum has resolved this issue . . . only hope that the Roku/Spectrum interface continues to work.  Are you able to provide suggested moves in the event that this problem reoccurs?  Thank you,.

Best Answer

  • James_MJames_M Posts: 2,342 ADMIN
    Aug 15, 2019 Accepted Answer

    There was a recent update to the Spectrum TV app to address a few issues, including the app crashing.  Typically, deleting and reinstalling the app will resolve most issues.  If the issue should return, please let us know.     

This discussion has been closed.