Welcome to the Spectrum Community

Get answers, share solutions, help your community.

Start here

Printer Loses Wifi Connection

depawldepawl Posts: 15
in Home Networking Jan 13, 2020

On the advice of Spectrum I recently upgraded my modem/router, even though I wasn't having any issues with the old one. The new one I got from them is a Technicolor TC8717T. I have an Epson XP-630 wireless printer, and now everytime I want to print I have to re-enter the wifi password. Never had this problem before and nothing else has changed.

Any suggestions?



  • RAIST5150RAIST5150 Posts: 835 ✭✭✭✭
    Jan 13, 2020
    Make sure sure the printer's IP address is not changing. Bind it in DHCP and then manually set it to use that address statically. Along with giving it a static address to save the password for, it will also speed up the resynch when it resumes from sleep/offline states.

    If your system(s) recently had Windows updates, they may have monkeyed with the authentication scheme again... has happened a few times in the past.

    Can try manually checking for follow up updates in the settings/security menus to see if they issued a patch for the patch. Could also check for driver/firmware updates for the printer.
  • depawldepawl Posts: 15
    Jan 14, 2020

    Thanks. Assigning a static ip to the printer appears to have solved the issue.

  • depawldepawl Posts: 15
    Jan 15, 2020

    Sorry. Guess I jumped the gun.  Printer worked fine for 3 or 4 times yesterday, but today the same issue reappeared. Have to reenter the wifi password to get it to work. Has to be something to do with the new Spectrum modem/router. Has been working fine for years before the modem was replaced.

  • depawldepawl Posts: 15
    Jan 19, 2020

    OK after further review it appears that my new Technicolor modem/router occasionally restarts on it's own. Not sure how frequently this happens but noticed yesterday that all the lights went out, then slowly came back on as it rebooted.

    Seems my other devices reconnect automatically after this happens but the printer does not.

    So it appears to be a modem/router issue rather than a printer issue.

This discussion has been closed.