cloud DVR has been repeating sections of shows

MarlouMarlou Posts: 5 ✭✭✭
edited August 21 in Spectrum TV for Roku Devices Aug 21, 2020

For the last two to three weeks we watch a show on cloud dvr and for example, get to 15 minutes in the show. Fast forward two minutes and hit play. The scroll bar at bottom of the screen shows 17 minutes as correct but instead we are seeing the very beginning of the show repeated again! Need to fast foward and rewind a few times to try to get back to the righg spot, but often we just give ip and try to watch from the beginning again at minute one.

If we continue watching it will cut off the last 15 - 20 minutes of the show. This happens regardless if the show is still being recorded or it was on earlier and is done. Especially frustrating when it happens near the end, like fast forward to minute 45 and it starts playing the segment of the show from minute 20. Sometimes we just need to give up, delete the show and wait for On Demand the next day.

Choice tv

Cloud dvr

2 Roku apps & XBox One app - all devices do the same thing.

Accepted Answers



  • Julia_RJulia_R Posts: 4,407 Lead Mod
    Aug 21, 2020


    Good morning! Welcome to the Spectrum Community.

    Currently the Cloud DVR is not compatible with the Xbox One, I would expect there to be some problems using that device. What generation of Roku are you using? I want to try and narrow down where the issue maybe coming from.

    When you are trying to get back to the same spot using the FF and Rewind does the progress bar follow correctly for that action?


  • MarlouMarlou Posts: 5 ✭✭✭
    Aug 21, 2020

    Thank you!

    Roku 3900X Roku Express

    Software 9.3.0 build 4194-51

    We have seen this behavior on two Roku sticks (same model etc). Yes we see the progress bar move as expected, but then the video segments played do not match to where they should based on the minutes elapsed / bar. This has also been seen on CBS occasionally without fast forwarding- ie 40 minutes into the show will start to repeat the 20 minute portion.

    Thank you for the help

  • dc_dcdc_dc Posts: 2 ✭✭
    Aug 26, 2020

    I'm having the same problem regardless of device (roku 3, roku express). The problem seems to be in the recording. Watching the basketball game, about 2/3 of the way through the game, suddenly I'm watching about 1/3 of the way through the game. If I fast forward, the last 1/3 is missing, the first 1/3 is repeated. Something is seriously broken. Every attempt to find the last 1/3 of the game fails - logging out, fast forward/rewind, switching devices. Last 1/3 of game is gone.

  • FinzzFinzz Posts: 2 ✭✭
    Aug 26, 2020

    Same issue here too... I have it happening on Roku and Apple TV. When FFing past commercials, it’ll jump me back to the beginning. The progress bar will show the correct location usually (it seems), but the video that plays is from the beginning. It also seems to happen more when I FF past the commercial and have to rewind a bit to get to the right spot after the commercials. Seems to happen a lot. Very frustrating! Exiting the recording and going back in usually corrects the issue until it happens again.

  • tomscot2tomscot2 Posts: 2 ✭✭
    Aug 26, 2020

    I'm having the same problems on my 2 Roku devices. This happens when I enter a program that is recording and I jump back to the beginning. That recording is then the same corrupted recording on all of my Roku devices. However, if I access it from my chrome browser via, the recording is as it should be. this has been going on for several weeks. It totally disrupts my watching the CBS Mornning News that starts recording at 7:00 am, but end up missing most of it. it seems like it if start teh replay at 7:58 it goes for an hour and then replays the hour that I just watched, with tending being at 7:58 at time stamp 1:59

  • TanTaeTanTae Posts: 1
    Aug 28, 2020

    My main TV (Roku) has been skipping way too much to the point I stop watching, get to a point on the cloud dvr and it goes to the beginning, my dvr box did not do that, my tv w the roku Express does the same thing! Start a show fast forward and boom back at the beginning. It makes no sense, I was told the cloud dvr does the same as the dvr box? Beyond frustrating!!

  • MarlouMarlou Posts: 5 ✭✭✭
    Aug 31, 2020

    Hello all, Original Poster here again. Spectrum sent out a technician because of "errors in the modems logs". He checked cabled, replaced connectors that looked corroded and checked cables in the nig box out by the front lawn. He said its probably an issue in the app itself.

    We have already tried to remove it and reinstall per instructions of the phone support person. We still have this issue happening on multiple shows, multiple channels. No matter how many times we stopped tge playback, leave app and go back in it keeps happening.

    Going to call support back again.

  • Grody_BGrody_B Posts: 2 ✭✭
    Sep 06, 2020

    Just switched to Spectrum from Uverse two weeks ago. I am having the same issue with the Apple 4K TV, which apparently cannot be returned.

  • MullzeyMullzey Posts: 14 ✭✭✭
    Sep 09, 2020

    Spectrum - why aren't you fixing this?! I posted 3 weeks ago about this horrible app. It looks like whatever update your team did 3 weeks ago was disastrous. We all have the same issues! I got no response from this forum for 2 weeks so I called Support AGAIN. I was told we need a new modem. NO I don't need a modem. I need your programmers to BACK OUT THE LAST UPDATE. My Roku is 4K and streams 4K on Prime & Netflix seamlessly. YOUR APP IS THE PROBLEM. Im sick of DVRd shows stopping, rewinding on their own, or just kicking me out of the Spectrum app completely. For the last 3 weeks I have NOT been able to watch ONE show in its entirety. FIX YOUR APP FOR ROKU. You owe us a discount on our bill. This is beyond ridiculous!

  • Dc4l73Dc4l73 Posts: 1
    Sep 09, 2020

    I've only had this service for one month and this just started a couple weeks ago for me. I can't even use the dvr anymore. I'm tempted to cancel and go back to YouTube TV.

  • James_MJames_M Posts: 2,453 ADMIN
    Sep 11, 2020

    I think I might have found a fix for this. I have a Roku express and was having the exact same issues with the repeating segments and recordings cutting off early. What I found is if you change the dvr settings for your shows, extend the end time by 30 minutes, the problems no longer occur. I tried this on a few of the channels I was having the problems with and this worked.

    Thanks @Ryan_1800 ! If anyone else has tried this and it works for you too, please let us know so we can mark it as a solution and share it with our product and support teams.

  • PeacefullyRiots_1PeacefullyRiots_1 Posts: 1
    Sep 12, 2020

    I have the same problem. I have the Apple 4K box and first of all the remote interface is terrible. The interface alone has had my blood pressure spike. When you add it the the playback problems I’m lucky I’m not in the intensive care. So frustrating I talked to spectrum tech and he acted line this is the first he has heard of this issue. I will try the settings fix but need other ideas

  • Ryan_1800Ryan_1800 Posts: 2 ✭✭
    Sep 13, 2020

    One additional note on extending the dvr settings. I've found that you have to let the program finish recording before you try to watch the show. If you play the recording while the show is still in progress you get the same problems with repeating segments., etc.

  • MarlouMarlou Posts: 5 ✭✭✭
    Sep 16, 2020

    Thank you Ryan_1800 I will give that a try with this weeks recordings! I hope it works but you would think that Spectrum would have known how to program a dvr if they offer one.

    Will let you know

  • Gregogreg21Gregogreg21 Posts: 1
    Sep 21, 2020

    HOW IS THIS NOT FIXED! I’ve lost the end of NBA finals and now the emmys. It’s not my Apple TV it’s like everybody says it’s the recording, it’s looped in the middle when you try to play the end of the show you can see the thumbnails of the end of the show, but you can never get to it it just loops the beginning no matter where you land in the timeline. This is majorly awful and unusable as a DVR. Please follow up and fix this I expect to see some comments from someone at spectrum follow up on this ASAP I will be checking the board again in the next days and calling you guys.

  • JimG19JimG19 Posts: 4 ✭✭
    edited September 22 Sep 22, 2020

    There was an app update for my Roku Ultra today, but this has still not been fixed! If you start watching a recording of a show that is still airing, it gets about halfway through and starts repeating itself. The customer must wait until the show ends to start watching a recording for the proper behavior. So instead of a dvr, spectrum has created a vcr. It's 2020 and something like this to go on for months shows a total disregard for your paying customers. And for some moderator here to mark it "fixed" is a travesty.

  • PaulMirandaPaulMiranda Posts: 2 ✭✭
    Sep 25, 2020

    This happens on my Apple TV (4th gen). If you are watching a show through cloud DVR, and another show starts recording OR stops recording, it causes the currently watched show to stop at that point and you can’t watch your current show past that point unless you force close the Spectrum app and reopen. It will also happen if watching the same show being recorded (time shifted). It won’t let you watch past the point you were watching, when it stops recording.

  • MarlouMarlou Posts: 5 ✭✭✭
    Sep 25, 2020

    OP also concurs that this is not resolved at all. We have been unable to finish watching most of the shows we have recorded for the last couple of months. DVR is kind of useless if you cant see an entire episode

  • TechVoyagerTechVoyager Posts: 3 ✭✭
    Sep 29, 2020

    Same issues here. cDVR w/ROKU's in family and bedroom.

    Same issues

    present since on or before middle of September.

    Issues include:

    Scheduled shows not recording/not available for playback on library

    Recorded programs partially recording

    Playback of recorded programs ending abruptly before end of the show resulting in resume message

    Resumed playback results in repeated portion of recorded program

    I contacted Spectrum tech support on 09/22/2020 and reported issue. I was advised to uninstall Spectrum app and re-install. Did so and problem still persists.

    I'm calling Spectrum today and ask for credit. as I'm paying for a service that I'm not receiving.

  • TechVoyagerTechVoyager Posts: 3 ✭✭
    Sep 29, 2020

    Update: I called billing and requested a credit which I got for the past month of cDVR service. I was transferred to tech and advised him of the ongoing issue and was told that this is a known issue and is being worked on. Will monitor and see if Spectrum resolves issue.

  • Sandy_S3Sandy_S3 Posts: 1
    Sep 30, 2020

    Same problem and no recording additional time didn't help. I automatically record an additional 30 minutes for basketball games and even record the following show. Just tried to watch the Presidential debate and same problem, rewinds before the end.

  • JackieSJackieS Posts: 1
    Oct 03, 2020

    I am having the exact same problem. Just started using Spectrum and am not off to a good start. Will prob be changing after this. Ridiculous

  • MichCabMichCab Posts: 1
    Oct 07, 2020

    Just switched over this week to Cloud DVR from standard Spectrum cable (using Apple TV 4th Gen) and BOTH shows I have recorded have seen this same error (yes, I started watching both of them while they were still recording). Getting the same errors as others have suggested: there are strange loops where half of the show is repeating. Just recorded Game 4 of the NBA Finals and my recording is 2 hours and 30 minutes long. At the 2 hr, 26 min mark, the game is at halftime?!?!

    Also tried watching on my iPhone... same errors.

    However, another user suggested that watching the recording from their Chrome browser through did NOT produce any errors. I CAN CONFIRM THIS WORKED! (for me) The recording was intact and moved fluidly from start to finish. Is this a fix? NO! At least it allows us to finish watching the recording, while Spectrum programmers work on a fix. (We'll just output HDMI from the laptop to the TV or AirPlay it). I will be contacting support for a credit to our Cloud DVR service for this month and EVERY month that the error goes unfixed.

  • Road_Work_AheadRoad_Work_Ahead Posts: 2 ✭✭
    edited October 7 Oct 07, 2020

    I have been having the same issue since I started Spectrum a couple weeks ago. I found if I go to the web page access I do not have the problem. The issue appears to be specific to the Roku interface interaction. The web page interface has a 30 second jump forward and back capability which I prefer to the Roku ffwd / frev interface.

  • CJH731CJH731 Posts: 1
    Oct 08, 2020

    Same problem here. One of the techs called it "Looping", another tech denied knowing anything about the problem. For what it is worth: Watched Wheel of Fortune, Season 38, Episode 16 on TV fed through Roku and on my Google Pixel 2 Phone with Spectrum app simultaneously watching for the glitch - surprise the Roku-TV stopped and the Pixel kept on playing. Funny thing I noticed was that the timeline on the TV showed 31 minutes 38 seconds. Same exact point in the show on the phone timeline showed 16 minutes 28 seconds. Serious clock problem here. Have not seen anything like this since working on computer hard drives in 1993 - clock problems were a huge problem way back when, and caused a lot of compatibility problems.

    Come on Spectrum - the problem is with the app you provide for Roku - you need to fix this - PLEASE!

    My next step if it is not fixed is to call and ask for refund of the cloud DVR part of my bill - after all the only access to the cloud DVR is through the Spectrum App.

  • MrsmooseMrsmoose Posts: 2 ✭✭
    Oct 11, 2020

    I'm having the same problem with "looping" . Also, the inability to where you are when fast forwarding is ridiculous. The service should be free until it actually works!

  • Steph_SSteph_S Posts: 291 ✭✭✭✭
    Oct 11, 2020

    Good Afternoon, I would like to advise that this is a known issue and our engineers are aware and working to resolve.

Sign In or Register to comment.