Advanced Search Options


We have advanced search options to make it easier to locate posts, questions and answers on this community.
More information can be found at Advanced Search Options
If you are looking for something specific, please check if someone else has already asked or answered the same question.
Before posting a new question, please check out our Internet / WiFi and Spectrum TV App troubleshooting pages for common issues, as well as useful information to include in your post.

Cannot log in to spectrum.net, getting maintenance in progress message

Sue53Sue53 Posts: 3 ✭✭
edited November 2020 in Managing & Using your Spectrum Account Nov 17, 2020

My internet is working fine but this month I am not able to login to spectrum.net to pay my bill. I keep getting "Maintenance in progress" on both the web site and my android app from my home. This has been going on for at least a week now and doesn't seem right.

I was able to login from a family member's computer in a different zip code to pay my bill.

Accepted Answers

  • James_MJames_M Posts: 3,109 ADMIN
    Nov 17, 2020 Accepted Answer

    Thanks. It sounds there is an issue on the network, possibly an update. Please try restarting the modem and let us know if that resolves the issue. If it does not, please reply back with the OS you are using ( I assume Windows) and the version currently installed.

  • Sue53Sue53 Posts: 3 ✭✭
    Nov 17, 2020 Accepted Answer

    YES, that did work. I unplugged my modem and router and disconnected the modem coax cable for a few minutes. So now I AM ABLE to access my account page.

    Thank you!!!

Replies

  • James_MJames_M Posts: 3,109 ADMIN
    Nov 17, 2020

    Hi,

    Sorry for the frustration. There has not been an issue reported with the website or the app. I have a couple follow up questions:

    1. Which internet browser are you using?
    2. Have you tried any other steps, such as restarting the modem or clearing the browsing history?


    Thanks.

  • Sue53Sue53 Posts: 3 ✭✭
    Nov 17, 2020

    Hi, I have tried to login on Chrome, Firefox and Edge on the internet with the same results. I did clear my history but still says "maintenance in progress".

    I tried logging into the website on another computer under a family member's chrome account in my household with no success either.

    The only way I am able to access my account via the website is to use a VPN and after all of the security of "I am not a robot", I can then access my account.

    The app I also tried is the MySpectrum on an android phone. It also says "maintenance in progress" thru wireless, but I can access it if I turn off the wireless connection and go directly thru 4G.

    I have not restarted my modem or wireless router since everything is working smoothly here with the exception of accessing my account online.

This discussion has been closed.