Before posting a new question, please check out our Internet / WiFi and Spectrum TV App troubleshooting pages for common issues, as well as useful information to include in your post.

Advanced Search Options


We have advanced search options to make it easier to locate posts, questions and answers on this community.
More information can be found at Advanced Search Options
If you are looking for something specific, please check if someone else has already asked or answered the same question.

Frequently Asked Questions


(Quick links to the current most searched topics)
How can I pause and rewind live TV using the Spectrum TV app?
Spectrum TV App Supported Devices

Smart plug unable to connect to upgrade

Missmy24ghzMissmy24ghz Posts: 9 Spectator
edited November 23 in Connectivity Oct 18, 2022

I have reviewed your answer to previous questions about smart plugs. Your answer says:

“The router would automatically assign the best network for the device. If the device only has 2.4ghz and not 5 ghz it should be able to connect to it.”

This does not appear to be so. I cannot even see my wifi network when setting up my plug. What is the correct resolution for smart plugs? It is hard to believe that smart plugs are worthless with the “upgrade”. Was this not tested?

Best Answer

  • HT_GreenfieldHT_Greenfield Posts: 139 Contributor
    Oct 21, 2022 Answer ✓

    The Amazon Smart Plug, like many small & simple IoT devices, only does 2.4-GHz 802.11n and, even at that, can only be joined to a WLAN intermediately. Amazon’s “Wi-Fi simple setup” is not absolutely simple but, once set up, is simple compared to other ways and means. The whole get-up cleverly enables the Echo Dot to somehow relay the 2.4 GHz media access control layer connectivity to the smart plug via the device running the Alexa app even if that device is connected at 5 GHz (i think.) 

    Make sure you’ve “saved your Wi-Fi passwords to Amazon” and use the Echo Dot as the “helper device” and go from there. If any problems, try re-upping the Echo Dot’s Wi-Fi connection and re-saving your Wi-Fi password(s) to Amazon and re-setting the smart plug.

    Saving Your Wi-Fi Passwords to Amazon FAQs

    Amazon Frustration-Free Setup Frequently Asked Questions

    Reset Your Amazon Smart Plug

Replies

  • James_MJames_M Posts: 3,772 ADMIN
    Oct 18, 2022

    Hi & welcome!

    What kind of smart plug are you using? Are you having trouble connnecting any other devices?

  • Missmy24ghzMissmy24ghz Posts: 9 Spectator
    Oct 20, 2022

    Amazon smart plug compatible with my echo dot. It worked fine before the upgrade. Now it does not connect and I cannot even see my wifi name. And I cannot add the name. The error says “provisional error”

  • Missmy24ghzMissmy24ghz Posts: 9 Spectator
    Oct 20, 2022

    I had problems with my HP printer, but worked around that by reading on line posts and restoring network defaults. Nothing like that happens with the smart plug.

  • Missmy24ghzMissmy24ghz Posts: 9 Spectator
    Oct 21, 2022

    I will try that today and get back to you with questions. Thanks.

  • Missmy24ghzMissmy24ghz Posts: 9 Spectator
    Oct 21, 2022

    You were helpful but….My wifi password is saved to Amazon, simple set up is enabled, I have re-upped the echo dot, reset the smart plug. All to no avail.

    It seems odd that my wifi does not appear when setting up the plug. Many names do appear, but not mine. I cannot enter mine and the password without getting “Provisioning error”

    what else can i try

  • HT_GreenfieldHT_Greenfield Posts: 139 Contributor
    Oct 22, 2022

    So the Echo Dot isn't helping & here are three things to try to get it helping: 1. Delete the smart plug profile from the Alexa app and reset the plug and try again. 2. Delete and reinstall the Alexa app and try again. 3. Restart the wireless router and try again. Let me know if that doesn't help and also if the Echo Dot shows up in the Alexa app and whether you have an Android device you could use to run the Alexa app on at least just long enough to get the smart plug connected.

  • Missmy24ghzMissmy24ghz Posts: 9 Spectator
    Oct 22, 2022

    Oh my. I did as you asked and now my echo dot will connect to my wireless. I get a blue light but not an orange. Now it says no network found. I reset my router again but the same thing is happening. I feel like i just went backwards.

  • Missmy24ghzMissmy24ghz Posts: 9 Spectator
    Oct 22, 2022

    My echo dot is back! So we are back at square one. Would Spectrum have renamed a wireless just for 2.4? The reason I ask is the networks that do appear - not mine - several have 2.4 with the network name. That seems strange unless several people did not get 5 G. Highly unlikely.

  • HT_GreenfieldHT_Greenfield Posts: 139 Contributor
    edited October 23 Oct 23, 2022

    I think the problem is how the plug can only be intermediately joined to the WLAN via media access control relay. Which is easy to work around without unified SSID. With unified SSID, you need another work-around and this article describes some of them. If your Alexa app device is Android, i recommend the first work-around, here, with the Wifi Analyzer and Wifi Connector Library apps.

    https://pocketables.com/2018/05/how-to-set-up-that-2-4ghz-device-on-your-dual-ghz-network.html

  • Missmy24ghzMissmy24ghz Posts: 9 Spectator
    Oct 24, 2022

    I will see if I can resurrect my kindle fire. That is an android. The link you just sent is interesting. If I can get the Kindle working I will try those suggestions. I did try setting the plug up with a hot spot Amd I tried to log into my router with the user name and password on the router. Neither of those suggestions worked I noticed on my friend’s router the light still blinks for 2.4. She lives around the corner 😕

    stay tuned. I am not giving up.

  • Missmy24ghzMissmy24ghz Posts: 9 Spectator
    Oct 24, 2022

    Hallelujah! I finally found something to work. Thanks to your constant help with this issue. After re reading your latest link - which was fantastic- I was successful in setting up a hotspot and that saved the day! Thank you so much!

  • HT_GreenfieldHT_Greenfield Posts: 139 Contributor
    Oct 26, 2022

    That's good to know @Missmy24ghz ! My compliments to you for being able to get that hotspot work-around to fly! 🖖🏻

This discussion has been closed.