Before posting a new question, please check out our Internet / WiFi and Spectrum TV App troubleshooting pages for common issues, as well as useful information to include in your post.

Advanced Search Options


We have advanced search options to make it easier to locate posts, questions and answers on this community.
More information can be found at Advanced Search Options
If you are looking for something specific, please check if someone else has already asked or answered the same question.

Frequently Asked Questions


(Quick links to the current most searched topics)
How can I pause and rewind live TV using the Spectrum TV app?
Spectrum TV App Supported Devices

Unable to Stream on Apple Devices and watch.spectrum.net

dlcrowdlcrow Posts: 7 Participant
edited January 11 in Spectrum TV for Apple & Apple TV Jan 06, 2023

I am a Spectrum cable subscriber and services through my TiVo with CableCard are working just fine. However, I am having a problem using the Spectrum TV app for streaming inside of my home on everything but the Roku platform.

Using watch.spectrum.net from a browser (tried with Safari, Chrome, and Firefox and have disabled all ad blockers) displays WLP-999 or WLP-4004 when tuning any channel. This includes Spectrum News, base cable channels like locals, and premium channels like HBO. The failure on the Spectrum News channel takes much longer to occur than the failure on other channels.

The Spectrum TV app on iOS displays ILP-999 or ILP-9000 when tuning any channel. The app on AppleTV displays ALP-1001 or ALP-999 when tuning any channel.

VOD from all of those applications (browser, iOS, and AppleTV) also fails. It shows Loading or Buffering, but never starts. It finally fails with IVP-1001 or IVP-1004 in iOS, AVP-999 on AppleTV, and WVP-4004 on watch.spectrum.net.

The Spectrum TV app on Roku on the same home network works perfectly for all functions (live tv, vod, etc.). And the iOS devices work just fine for channels that do not require to be on the home network when the device is connected via another service provider (e.g. AT&T cellular or WiFi at another location). All I have to do is disable my home wifi causing the primary route to be via AT&T cellular, tune another channel, and it immediately streams correctly. Because of this, I believe that authentication is setup appropriately in the applications.

What I read in various internet forums about this, it seems that some authentication is supposed to happen within my cable modem when I am on my home network. I have power cycled the modem as well as gone through the reset flow in the Spectrum web site troubleshooting with no change in behavior. I have also signed out from the iOS and AppleTV apps and re-authenticated as well as force quit the apps and rebooted the devices without any change in failing behavior. For the AppleTV app, there is a choice for "automatic authentication" or "manual authentication". I have tried both without any change in failing behavior.

Any thoughts on what could be wrong and what the appropriate path to resolution should be?

Best Answer

  • dlcrowdlcrow Posts: 7 Participant
    Jan 07, 2023 Answer ✓

    I did some more investigation using browser tools to try to figure out what was failing in watch.spectrum.net. I now know that it is a DNS Issue. I have a local caching DNS server on my home network and for some reason it is not resolving the CDN web site that delivers the video content (in this case it was cip4-204672b036.linear.stvacdn.spectrum.com). As soon as I changed configuration on a device to use the DNS servers provided by the Spectrum DHCP or other public DNS servers, everything works in every environment. I guess the Roku must have some built-in fallback for resiliency that allows it to succeed when others fail.

    Thanks for the engagement trying to help. At this point, I'll have to figure out what is wrong with my DNS server, but I now know where the problem is and it is mine to fix.

Replies

  • Renee_TRenee_T Posts: 416 Moderator
    Jan 07, 2023

    Hello @dlcrow


    Welcome to our community! I'm sorry to hear about the difficulties with the app. I just have a couple of questions to try to help us pinpoint the issue. I used your community login information to look at the account and I see that you're using a separate modem and router. When you power cycled the modem, did you power cycle the router as well? When you were checking the website, what browser are you using? And lastly, on the iOS/Apple TV, are you using either the Single Sign on or autofill features?

  • dlcrowdlcrow Posts: 7 Participant
    Jan 07, 2023

    I power cycled both the modem and router. I powered both off and disconnected the Ethernet between them. I then powered up the modem and let it complete it's boot into the "online" state, then reconnected the Ethernet, and then powered up the router.

    I have attempted to use Safari, Chrome, and Firefox on macOS 13.1 and Firefox on Windows 11. All behave exactly the same. I cleared all local data (cookies, local storage, and session storage) from the browser. And I did a complete reset with a new browser profile. No change in behavior.

    On the AppleTV and in the browser, I have tried both the "click continue" skipping authentication as well as the explicit username/password authentication. On the AppleTV and the iOS devices (iPhone and iPad), I have deleted the Spectrum TV app and re-installed it from the app store - rebooting the device in between the uninstall and install. I have also logged out of the TV Provider in the general settings and re-authenticated there.

    Basically, I've reset, undone, and re-done everything possible that I can think of.

This discussion has been closed.