You are currently viewing the Spectrum Community Archives
This content may be outdated or inaccurate
All posts are closed and commenting has been disabled

If you have a question or comment, please start a new post (registration is required)

Leave the Archive

How can I unblock desired texts?

user12
user12 Posts: 6 Spectator

After switching from ATT to Spectrum (keeping my phone number), some (but not all) of my texts are being blocked. Most of the blocked texts are short code (5 digit numbers), but some of these are delivered. How can I fix this?

Best Answers

  • Jaleesa_F
    Jaleesa_F Posts: 152 Moderator
    Answer ✓

    Hello and welcome to the Community!

    I am happy to assist with your inquiry. What type of mobile device are you using?

  • Tyleen_Z
    Tyleen_Z Posts: 576 Moderator
    Answer ✓

    Thank you for that information. From what I understand the blocking of any numbers is done manually by a customer. We do not block any messages/calls etc from getting to you.

    You would need to go to settings then messages. Under SMS/MMS tap blocked contacts. There is also the option for filtering unknown senders. If you select this then it will filter unknown senders into a separate folder.

    If you have further issues past these settings you would need to reach out to Apple to see why some messages are blocked and others are not as any phone carrier would not control what to block.

    -Tyleen

Answers

  • user12
    user12 Posts: 6 Spectator

    iPhone SE, iOS 16.3

  • user12
    user12 Posts: 6 Spectator

    NO messages are blocked in Settings and "Filter unknown senders" is set to OFF. I have rebooted my phone several times. I have also switched WiFi, airplane mode, and "Filter Unknown Senders" off & on several times (as each of those have been reported to help). Apple support states that with those setting my iPhone would not be blocking any texts. I have also checked with tech support at the financial institution sending the verification codes and their system shows those texts as being sent & blocked by the receiving phone (mine). These verification texts were working perfectly (multiples each week) and only stopped when I switched from ATT to Spectrum. Spectrum Mobile is the ONLY variable I see that changed just before the issue.

  • HT_Greenfield
    HT_Greenfield Posts: 450 Contributor

    I can only imagine why but try to re-up your opt-in by sending the keyword START to the short code. If no worky, then try HELP in which case you may receive a reply with instructions on how to re-up/opt in.

  • user12
    user12 Posts: 6 Spectator

    HT- Appreciate the suggestions, but already tried that with ALL numbers the financial institution uses to text its customers. Also tried using cellular vs WiFi connection. I have also removed ALL numbers from my blocked call list (hello again robo calls 😕). I spent over an hour on the phone with the institution's tech support & we found that ALL texts from that firm are being rejected by my phone, not just short codes. Not promptly getting critical account & security notifications is a real issue. They have escalated up their tech support 'team', but no answer so far.

    I was brainstorming that it might somehow be due to Spectrum Mobile being an MVNO, but presently I have no evidence to support that.

    Since there are multiple internet reports of similar issues with other carriers (inc. the Big Three), I'll try to post a fix if I find one.

  • William_M
    William_M Posts: 761 Moderator

    @user12 Will you please try resetting your network settings, turn off your device, remove and reinsert the SIM card, turn it back on and test to see if the issue persists?

  • user12
    user12 Posts: 6 Spectator

    William_M

    Thanks for the suggestions.

    I had already reset my network settings (twice) without help. Good thought about re-installing my SIM card.... but now tried that without resolution either.

    A buddy who works in tech suggested I might have a bad SIM card, but that seems unlikely to me considering the very isolated nature of this issue. He also wondered if somehow Spectrum Shield (Spectrum's security procedures) and/or the institution's security software/protocols might be involved? That is WAY outside my expertise.

  • HT_Greenfield
    HT_Greenfield Posts: 450 Contributor

    Who knows but it might just be a matter of time before that particular SMS service provider obtains and effects the correct routing code for your number since it's been ported to Spectrum Mobile. During the interim, it might still be routing to and being rejected by AT&T. You might be able to kick start such update process by just logging on to the account and disable SMS alerts and then wait for a couple of days and then re-enable it and see what happens, just for kicks. Pure speculation, though.

  • user12
    user12 Posts: 6 Spectator

    HT-

    Interesting thought. I did delete my mobile number completely from my institutional account, then re-added it. I had hoped that would force their system to re-initialize its text routing, if indeed it was still trying to route texts to ATT. I'll try disabling SMS alerts.....no harm in trying that since I am not receiving any from them anyway 😝

  • 35Years
    35Years Posts: 1 Newcomer

    Recently had the same problem - it resolved itself when we set up the voice mail. Worth a try

This discussion has been closed.