Anybody else having problems logging into Security Suite?

Akiva96 Posts: 1 Newcomer
edited February 6 in Community Archive

For weeks now I cannot "Open Security Suite" from the taskbar icon (or anywhere else). I get the following login screen.

When I enter my credentials, it just kicks me back to this screen with a message "Incorrect login. Please try again." I've tried uninstalling and reinstalling the program but no improvement. Support just says "we are working diligently on the issue but have no timeframe for a fix"

After a few weeks of this I question whether they are really working on this and if there will ever be a fix.

My other issue is (and I'm going to yell now haha): WHY DID THEY NOT INFORM THEIR CUSTOMERS THAT THEY ARE HAVING A PROBLEM WITH THIS???????????

Best Answers

  • DHorton
    DHorton Posts: 1 Newcomer
    edited January 19 Answer ✓

    Here is what to do.... Sign into your Spectrum account.. Add a New Person.. Click on Invite... Go to your email address and click on Create User in the email. Give the New User Administrator status. Sign out and Sign in under the New User account.... Uninstall Security Suite from your computer.. Download and install again.

  • Tom_S
    Tom_S Posts: 1 Newcomer
    Answer ✓

    I've had this problem for 3 weeks and finally talked to someone that solved the problem. I'm using Windows 11.

    I uninstalled the security suite

    Deleted all downloads from my browser, chrome (or just the charter spectrum downloads)

    Ran an f-secure Uninstaller program sent from Spectrum

    Then downloaded the security suite with a NEW license (not the one that was originally used)

    This finally solved the problem!


  • sacomoco
    sacomoco Posts: 1 Spectator
    edited January 18

    I cannot login to security suite to run a full scan i do have the icon on my tool bar, but it won't open to run a scan unless I put in a login user n password, I have tried my information, but it won't work. can anyone tell me what to do in this case

  • pherasimchuk
    pherasimchuk Posts: 3 Spectator

    I am having the same issue exactly. I did try resetting the password but never receive the email and yes I did register previously.

  • Jim72
    Jim72 Posts: 2 Spectator

    Same here. Just spoke to spectrum support did the uninstall/install dance. No go....they really don't seem to know. I also think a customer wide release explaining there is an issue should have been done. To leave customers unprotected is just wrong.

  • EricLP
    EricLP Posts: 1 Newcomer
    edited January 23

    Tried both of these solutions but the problem persists.

  • mes
    mes Posts: 1 Newcomer

    Also tried both solutions (uninstalling with uninstaller and reinstalling AND creating a new user) and neither worked. Creating a new user didn't help. Still getting the log in screen. It's a known issue with Spectrum. They are hoping to have it resolved in 72 hours, but this has been ongoing since last week for me. No email will be sent when you request to change the password, so the password can't be changed. Also, no log in or password was actually added; the security suite used to just open. Spectrum needs to fix it.

  • Uno
    Uno Posts: 1 Newcomer

    @mes I am having the same issues. Tried everything as you did but didn't help. Spectrum need to look into it.

    GKCZUBa Posts: 1 Newcomer

    I chatted with Spectrum on Jan 11 about this issue. At that time I was told they know about the issue and are working on it. I chatted with them again a few days ago and was told they are still working on it. It is now January 27 and still not working. By the way, I am able to sign into my Spectrum account OK...just can't sign in again when asked to sign in again while trying to reinstall Security Suite. Come on Spectrum....get this issue fixed!!

  • pherasimchuk
    pherasimchuk Posts: 3 Spectator

    Same issue here. Tried everything also and can lg into my spectrum account.

  • truekato
    truekato Posts: 1 Newcomer

    has anyone found out why security suite isn't working??? I've been trying to login to it for weeks now and cant reset the password or anything but i am able to login to very frustrating.

  • pherasimchuk
    pherasimchuk Posts: 3 Spectator

    This just worked for me. I downloaded the removal tool directly from the f-secure website.

  • STLMom
    STLMom Posts: 1 Newcomer

    As a Charter/Spectrum customer I have also been experiencing problems with Charter Security Suite, provided by F-Secure. The first problem I encountered on Jan 17, 2024. Security Suite showed a message stating subscription had expired. I contacted Charter tech support and was advised to uninstall using uninstall tool and reinstall. After uninstalling and rebooting, I reinstalled. A login message box appeared but did not recognize my charter password. I changed my password and attempted again. Same result. Did not recognize my password. I contacted Charter again and was informed they were working on the problem.

    After no additional response from Charter, I contacted tech support again TWO WEEKS LATER. I was told they had not resolved my problem but would continue to look in to it. They would call me today and update. Almost 5 pm, still awaiting phone call.

    I searched this problem and realized many people are having this problem, since the first week of January. I attempted some recommended solutions on the Charter thread from others posting this problem. Installing, re-installing, re-booting, no change. I deleted the computer listed on my license for Security Suite. Attempted to re-name computer and download Security Suite for a different name computer. The first page after clicking Download Security Suite allows me to type in a name for a computer, but will NOT allow me to select an operating system. The choice grays out and I cannot type in Windows. I never get to the actual download page.

    I have had security suite on my charter account for over 20 years and I AM SO DISAPPOINTED. This is absolutely ridiculous to think my security software has some sort of BUG! This is a software problem and should have been resolved a month ago.

    What is the solution????!!! I have been limiting time on my computer and turning it off. This is NOT a solution. If F-Secure cannot solve this problem, Charter needs to get a different security provider. I have been very impressed with F-Secure over the years, what is going on?

    Please provide a solution.

  • HT_Greenfield
    HT_Greenfield Posts: 604 Contributor

    @STLMom : stupid question: are you trying to download Security Suite on a computer running Windows 7?

    🔗 ↳ System Requirements ↳ Operating System


  • Jeff_K
    Jeff_K Posts: 1 Newcomer

    I just downloaded the F-Secure uninstallation tool from the F-Secure website (just search for it) Simply downloaded the security suite from spectrum afterwards and it worked this time. Didn't even have to restart or clear the cache. Hope this helps....

  • toecheese
    toecheese Posts: 1 Newcomer

    I had the same issue yesterday. I downloaded the F-Secure removal tool at After running it the installer still gave me the password prompt, but then I went to Spectrum's security suite site and deactivated the license for that computer. Then I re-ran the removal tool, activated a new license, and it installed with no issues. No password prompt box at all.

    I would strongly recommend against running a registry cleaning tool. In my opinion those are snake oil and can damage your system.