Nueva comunidad de Spectrum


Hemos creado una comunidad latina para darles a los clientes de habla hispana la opción de hacer preguntas y obtener respuestas en español. Comunidad Latina

Advanced Search Options


We have advanced search options to make it easier to locate posts, questions and answers on this community.
More information can be found at Advanced Search Options
If you are looking for something specific, please check if someone else has already asked or answered the same question.
Before posting a new question, please check out our Internet / WiFi and Spectrum TV App troubleshooting pages for common issues, as well as useful information to include in your post.

My Spectrum App - What is Customized Device Agreement? - Answered

2»

Replies

  • JohnfromMaineJohnfromMaine Posts: 1
    Jul 29, 2021

    I just got this error. I have been using the same Android S8+ for a few years, have been paying my Spectrum bill with it and this is a new error I got. I have no idea what rooted even is. not user friendly message at all.

    I have no indication from any of my other accounts there are issues yet I see a bunch of people writing here on this with a recent upgrade of the Spectrum application.

    I am in tech. if an upgrade has been done and lots of people are writing, what is the line of code that is causing this? How come we have not been sent any emails stating a new security issue. If there are that many with a 'potential' security issue, I would think Spectrums tech should be addressing what the issue is, as most people here are just customers and have no idea how to even understand this as I do not.

    Thank you.

  • Lisa64Lisa64 Posts: 5 ✭✭✭
    Jul 29, 2021

    I believe they have this question listed as solved. Because they don't seem to be answering it anymore. BS solved. You may have to start a new line of posts.

  • JimmyJoeJimBobJimmyJoeJimBob Posts: 1
    Jul 29, 2021

    Same issue. Opened the app to check for outage (there is one) and got the message shortly before my heart attack (j/k). Verified phone is not rooted using Root Check app, verified USB Debugging is off

  • gs713gs713 Posts: 1
    edited August 1 Jul 30, 2021

    I am getting this notification about rooted, jailbroken a/o USB debugging mode and my phone is none of these things. In the "solution" to the above post, it recommends contacting to dig into the issue in more detail. It suggests leaving a comment on that thread, but the responses I see seem vague and there are a few that don't appear to be answered. So I'm going to start a new post about this.

    I have an LG Stylo 4 (which I noticed that someone else who posted in the thread also had).

    That post has 740+ views, which is hundreds more than any other thread in the "Troubleshooting the My Spectrum App" category and so many are claiming the same: we haven't done these things to our phones. Something seems to have gone wrong with a recent update. Is there anything we can do to fix this or do we just have to wait and hope that they get around to it? That they even notice the problem?

  • slydr68slydr68 Posts: 2 ✭✭
    edited August 2 Jul 31, 2021

    Same error - in error. Samsung Galaxy S8 Active. Android 9.

    Also, it would also be nice if the customer support representatives knew anything about this error...no one I spoke to on the phone had any clue about this issue.

  • mcurtmcurt Posts: 1
    Jul 31, 2021

    Same issue using Galaxy S.8 It seems like your app team made a bad app. Good customer service is to fix the problem you guys created and not give excuses or alternative means to make it more difficult for your customers.. Wish you fix the problem soon.

  • James_MJames_M Posts: 2,999 ADMIN
    edited August 2 Aug 02, 2021

    I am posting a reminder that the accepted answer with detailed information is located at the beginning of this thread / post, the following is a brief recap of the detailed answer:

    If your device is rooted or jailbroken, the message is letting you know that you may be open to security vulnerabilities when using a jailbroken or rooted device, or a device where USB debugging is enabled to make payments. The message is meant to inform you of the risk of using bill pay on a rooted or jailbroken device.

    If you are getting a message on your mobile device alerting you to accept the Customized Device Agreement and you decide to not to accept, there are multiple other ways you can pay your bill, including:

    • Online at Spectrum.net
    • Try using a different mobile device
    • Your bank website
    • By mail
    • At a Spectrum Store (There is no processing fee when making a payment at our stores)
    • By phone using the automated system (NoteIf you choose to make your payment by phone with the assistance of a customer service agent, you'll be charged a $5.00 processing fee)

    I included a link to How to Pay Your Bill, which details each of the options above and provides answers to frequently asked questions.

    If you believe you are getting this message in error, please reply to this post with the device model information and the current OS version installed. We will forward your feedback.

    Thanks!

  • CclientCclient Posts: 0
    edited August 2 Aug 02, 2021

    The application suggests that my phone is Jailbroken/Rooted, which it isn't. I have turned off my usb Debugging setting, Restarted my phone and uninstalled and reinstalled the application, but the application still suggests my phone is jailbroken/rooted or has usb debugging on.

This discussion has been closed.