Before posting a new question, please check out our Internet / WiFi and Spectrum TV App troubleshooting pages for common issues, as well as useful information to include in your post.

Advanced Search Options

We have advanced search options to make it easier to locate posts, questions and answers on this community.
More information can be found at Advanced Search Options
If you are looking for something specific, please check if someone else has already asked or answered the same question.

Frequently Asked Questions

(Quick links to the current most searched topics)
How can I pause and rewind live TV using the Spectrum TV app?
Spectrum TV App Supported Devices

My Spectrum App will not open

jjam31jjam31 Posts: 1 Newcomer
edited March 15 in My Spectrum App - My Spectrum App Feedback Feb 02, 2023

The My Spectrum app will not open. I had to change my login info and ever since then the app will not open. It just keeps saying “Unable to Complete Service Request”. The only option it gives me to hut is “Retry”. It just keeps going in an endless loop. I cannot manage my equipment on my modem, and I have equipment that I need to reconnect. This needs fixed on the app ASAP please!



  • James_MJames_M Posts: 3,953 ADMIN
    edited February 2 Feb 02, 2023

    Hi & welcome!

    There are no known issues currenly imapacting app login. It sounds like your device is still trying to log in with the old login information. Most devices have an option to bypass autofill or auto login, or they have an option to clear old login data.

    If you are still having an issue, let us know and include the device you are using along with any other troubleshooting you've tried in you reply.


  • DstewDstew Posts: 1 Newcomer
    Mar 01, 2023

    I am having the same exact problem on my iPhone! I’ve tried deleting the app and reinstalling it, powering down my phone IOS 16.3.1 and restarting multiple times and I fall into the same loop described above.

  • James_MJames_M Posts: 3,953 ADMIN
    Mar 02, 2023

    @Dstew Hi & welcome!

    The app authenticates through the modem, please try restarting the modem on the account and let us know if the issue continues.

This discussion has been closed.