Welcome to the Community!


If you are looking for something specific, please use the search bar to check if someone else has asked or answered the same question before posting a new question. Check out our Community Instructions for other FAQ's.

The new feature "Call Guard" does not block the calls that nomorobo use to? You still get calls!!

JarheadJarhead Posts: 2 ✭✭
in Digital Phone Apr 30, 2021

Nomorobo blocked so many calls, and you could add numbers as needed. Call guard only blocks the 25 your allowed by Spectrum. Why change from something that was working so well? Nomorobo, only allowed the scam calls to ring one time, now all the calls come through as normal 4-6 ring calls and they leave a message. It may read scam call, but the phone still rings and they always call back everyday. There seems to be no blocking of calls at all? Again, why change. something that worked so well?

Replies

  • Paul_BPaul_B Posts: 320 MOD
    May 01, 2021

    Hello @Jarhead and welcome to the Spectrum Community. Have you logged into your account online to check your settings to make sure the Call Guard feature is turned on? If it is on, could you try to toggle off and then back on to see if that changes anything?

    Paul B.

  • JarheadJarhead Posts: 2 ✭✭
    May 01, 2021

    Spectrum only allows 25 numbers to be blocked, we get that many in one day now that they discontinued Nomorobo and went with call block that does not block a single call. All the calls ring 4-6 times with known scam caller ID's, Nomomrobo blocked all them once you let them know, then only one ring. Spectrum really blew this one in the time of so many robo calls, in the millions every day. I guess they are trying to save money, so go with a lesser quality company.

  • SatchSatch Posts: 4,057 ✭✭✭✭
    edited May 1 May 01, 2021

    Hello @Jarhead ,

    Call Guard has an infinite number of blocking options, and has nothing to do with the manual Call Blocking setting. Call Blocking allows you to turn on Call Block and allow up to 25 numbers of your choice to block.

    First, I would try Paul's suggestion. Turn Call Guard off and than back on to see if that changes anything. Make sure that when you turn Call Guard back on that you have also turned on Anonymous Call Rejection, and any other call blocking options in Voice Zone settings. Save changes.

    If you are still getting Spam and Robocalls with Call Guard and Spam Risk activated, Call Spectrum. Let Spectrum know that you have Call Guard turned on in "My Account," but it is not working. We have customers who have had Call Guard turned on in their accounts, only to call Spectrum and have Spectrum discover that all Call Guard and call blocking features were turned off! The CSR will be sure to activate Call Guard over the phone for you.

    Satch

Sign In or Register to comment.